[bug#77246,08/18] gnu: python-ncls: Update to 0.0.68.

Message ID 20250325075712.22316-8-ngraves@ngraves.fr
State New
Headers
Series [bug#77246,01/18] gnu: python-biom-format: Update to 2.1.16. |

Commit Message

Nicolas Graves March 25, 2025, 7:56 a.m. UTC
  * gnu/packages/python-xyz.scm (python-ncls): Update to 0.0.68.
[build-system]: Switch to pyproject-build-system.
[native-inputs]: Add python-cython, python-pandas, python-pytest,
python-setuptools, python-wheel.
---
 gnu/packages/python-xyz.scm | 16 +++++++++++++---
 1 file changed, 13 insertions(+), 3 deletions(-)
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1acc381d9f..26b4a76670 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3895,14 +3895,24 @@  (define-public python-ncclient
 (define-public python-ncls
   (package
     (name "python-ncls")
-    (version "0.0.65")
+    (version "0.0.68")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "ncls" version))
               (sha256
                (base32
-                "1wx06xqknd2r98w8z93f47g5dpxzn92kamhj8vkq0nj569hf7cg1"))))
-    (build-system python-build-system)
+                "14xsnzr34xa4rwfcdjry9aqjs8i03s9fzy6jgrwj3fr3n6msbal1"))))
+    (build-system pyproject-build-system)
+    (arguments
+     ;; Those tests fail with warnings (not errors) for the Numpy update.
+     ;; Remove it at next python-team iteration.
+     (list #:test-flags ''("--ignore=examples/test_all_overlaps_both.py"
+                           "--ignore=examples/test_find_overlap_list.py")))
+    (native-inputs (list python-cython
+                         python-pandas
+                         python-pytest
+                         python-setuptools
+                         python-wheel))
     (propagated-inputs (list python-numpy))
     (home-page "https://github.com/endrebak/ncls")
     (synopsis "Nested containment list data structure")