[bug#77246,07/18] gnu: python-cell2cell: Update to 0.7.4.
Commit Message
* gnu/packages/bioinformatics.scm (python-cell2cell): Update to 0.7.4.
[source]{origin}: Relax requirements in snippet.
---
gnu/packages/bioinformatics.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
@@ -2406,7 +2406,7 @@ (define-public python-bulkvis
(define-public python-cell2cell
(package
(name "python-cell2cell")
- (version "0.6.8")
+ (version "0.7.4")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2415,7 +2415,7 @@ (define-public python-cell2cell
(file-name (git-file-name name version))
(sha256
(base32
- "1hwww0rcv8sc4k312n4d0jhbyix1jjqgv5djg25bw8127q5iym3s"))
+ "02cqc5rm0qkm0np1k7bim1w7f5qjnwf1jcm5albd9cpvfs4bwgdr"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -2431,6 +2431,8 @@ (define-public python-cell2cell
(("'statannotations',") "")
;; We provide version 1.0.4, which should be fine.
(("'gseapy == 1.0.3'") "'gseapy'")
+ ;; We provide version 0.9.0, which should be fine.
+ (("'tensorly == 0.8.1'") "'tensorly'")
;; Using matplotlib 3.5.2 leads to this bug:
;; https://github.com/earmingol/cell2cell/issues/19 but we
;; can't package a different minor version of matplotlib