[bug#77246,18/18] gnu: python-aiosmtpd: Update to 1.4.6.

Message ID 20250325075712.22316-18-ngraves@ngraves.fr
State New
Headers
Series [bug#77246,01/18] gnu: python-biom-format: Update to 2.1.16. |

Commit Message

Nicolas Graves March 25, 2025, 7:56 a.m. UTC
  * gnu/packages/mail.scm (python-aiosmtpd): Update to 1.4.6.
[build-system]: Switch to pyproject.
[arguments]{phases}: Delete it.
{test-flags}: Switch a QA test.
[native-inputs]: Remove python-flufl-testing, python-node.  Add
python-pytest, python-pytest-asyncio, python-pytest-cov,
python-pytest-mock, python-setuptools, python-wheel.
---
 gnu/packages/mail.scm | 27 ++++++++++++---------------
 1 file changed, 12 insertions(+), 15 deletions(-)
  

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 8668cda211..23ecf8660b 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -4706,30 +4706,27 @@  (define-public python-authheaders
 (define-public python-aiosmtpd
   (package
     (name "python-aiosmtpd")
-    (version "1.2.2")
+    (version "1.4.6")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
              (url "https://github.com/aio-libs/aiosmtpd")
-             (commit version)))
+             (commit (string-append "v" version))))
        (sha256
-        (base32 "0083d6nf75xv8nq1il6jabz36v6c452svy4p402csxwwih5pw6sk"))
+        (base32 "0b5y94zc8pq75sjwsifblzgjnliyclkwypi68b2zffrxcdnz27r2"))
        (file-name (git-file-name name version))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'delete-failing-tests
-           (lambda _
-             ;; This test uses an expired certificate.
-             (delete-file "aiosmtpd/tests/test_smtps.py")
-             #t))
-         (replace 'check
-           (lambda _
-             (invoke "python" "-m" "nose2" "-v"))))))
+     ;; This QA test requires git.
+     (list #:test-flags ''("-k" "not test_ge_master")))
     (native-inputs
-     (list python-flufl-testing python-nose2))
+     (list python-pytest
+           python-pytest-asyncio
+           python-pytest-cov
+           python-pytest-mock
+           python-setuptools
+           python-wheel))
     (propagated-inputs
      (list python-atpublic))
     (home-page "https://aiosmtpd.readthedocs.io/")