[bug#77246,16/18] gnu: python-netaddr: Move to (gnu packages python-web).

Message ID 20250325075712.22316-16-ngraves@ngraves.fr
State New
Headers
Series [bug#77246,01/18] gnu: python-biom-format: Update to 2.1.16. |

Commit Message

Nicolas Graves March 25, 2025, 7:56 a.m. UTC
  * gnu/packages/python-xyz.scm (python-netaddr): Move from here…
* gnu/packages/python-web.scm (python-netaddr): …to here.
---
 gnu/packages/python-web.scm | 20 ++++++++++++++++++++
 gnu/packages/python-xyz.scm | 20 --------------------
 2 files changed, 20 insertions(+), 20 deletions(-)
  

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index af37cb5bef..4d4a6d9422 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4362,6 +4362,26 @@  (define-public python-ndg-httpsclient
     (home-page "https://github.com/cedadev/ndg_httpsclient/")
     (license license:bsd-3)))
 
+(define-public python-netaddr
+  (package
+    (name "python-netaddr")
+    (version "0.8.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "netaddr" version))
+       (sha256
+         (base32
+          "0hx2npi0wnhwlcybilgwlddw6qffx1mb7a3sj4p9s7bvl33mgk6n"))))
+    (build-system python-build-system)
+    (arguments `(#:tests? #f)) ;; No tests.
+    (home-page "https://github.com/drkjam/netaddr/")
+    (synopsis "Pythonic manipulation of  network addresses")
+    (description
+      "A Python library for representing and manipulating IPv4, IPv6, CIDR, EUI
+and MAC network addresses.")
+    (license license:bsd-3)))
+
 (define-public python-nh3
   (package
     (name "python-nh3")
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5c849ca6a2..4ff34b0551 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17221,26 +17221,6 @@  (define-public python-msgpack-transitional
                  ((".fromstring\\(") ".frombytes("))
                #t))))))))
 
-(define-public python-netaddr
-  (package
-    (name "python-netaddr")
-    (version "0.8.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "netaddr" version))
-       (sha256
-         (base32
-          "0hx2npi0wnhwlcybilgwlddw6qffx1mb7a3sj4p9s7bvl33mgk6n"))))
-    (build-system python-build-system)
-    (arguments `(#:tests? #f)) ;; No tests.
-    (home-page "https://github.com/drkjam/netaddr/")
-    (synopsis "Pythonic manipulation of  network addresses")
-    (description
-      "A Python library for representing and manipulating IPv4, IPv6, CIDR, EUI
-and MAC network addresses.")
-    (license license:bsd-3)))
-
 (define-public python-openstep-plist
  (package
   (name "python-openstep-plist")