[bug#77246,14/18] gnu: python-debtcollector: Update to 3.0.0.

Message ID 20250325075712.22316-14-ngraves@ngraves.fr
State New
Headers
Series [bug#77246,01/18] gnu: python-biom-format: Update to 2.1.16. |

Commit Message

Nicolas Graves March 25, 2025, 7:56 a.m. UTC
  * gnu/packages/openstack.scm (python-debtcollector): Update to 3.0.0.
[source]: Patch {origin} to remove unwanted native-inputs.
[build-system]: Switch to pyproject-build-system.
[propagated-inputs]: Remove python-six.
[native-inputs]: Add python-doc8, python-fixtures,
python-openstackdocstheme, python-reno, python-setuptools,
python-stestr and python-wheel. Remove python-subunit and
python-testrepository.
---
 gnu/packages/openstack.scm | 24 +++++++++++++++++-------
 1 file changed, 17 insertions(+), 7 deletions(-)
  

Patch

diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index ac283bd019..80fad32068 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -115,20 +115,30 @@  (define-public python-cliff
 (define-public python-debtcollector
   (package
     (name "python-debtcollector")
-    (version "1.19.0")
+    (version "3.0.0")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "debtcollector" version))
         (sha256
-          (base32
-           "06c7vyn184y9f0lsrwaz13aq63hdz5fjrd191b8nifx6acsni42f"))))
-    (build-system python-build-system)
+         (base32 "0vzarkvjclci98d8lvkix6qj59f7rxp1qg2x6q6is7qfbg91g29a"))
+        (modules '((guix build utils)))
+        (snippet #~(begin
+                     (substitute* "test-requirements.txt"
+                       (("^(coverage|hacking|pre-commit).*")
+                        ""))))))
+    (build-system pyproject-build-system)
     (propagated-inputs
-     (list python-pbr python-six python-wrapt))
+     (list python-pbr python-wrapt))
     (native-inputs
-     (list ;; Tests.
-           python-subunit python-testrepository python-testtools))
+     (list python-doc8
+           python-fixtures
+           python-openstackdocstheme
+           python-reno
+           python-setuptools
+           python-stestr
+           python-testtools
+           python-wheel))
     (home-page "https://www.openstack.org/")
     (synopsis
      "Find deprecated patterns and strategies in Python code")