[bug#77234,3/3] Add fcitx5-fluent-theme
Commit Message
Change-Id: I68893982d2a38178a54459b0e2b632ff9f97bedf
---
gnu/packages/fcitx5.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
@@ -676,3 +676,34 @@ (define-public fcitx5-nord-theme
dimmed pastel colors for a comfortable yet vibrant ambiance. It offers 2
versions: Nord-dark and Nord-light.")
(license license:expat))))
+
+(define-public fcitx5-fluent-theme
+ (let ((commit "399699ac7d366ed6c1952646ed71647e3c8f99b5")
+ (revision "0"))
+ (package
+ (name "fcitx5-fluent-theme")
+ (version (git-version "0.4.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Reverier-Xu/Fluent-fcitx5")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "188gsggh78gjf2kg9kxds819hxidc2yf5aivwbbqayw7cb2h5ijr"))))
+ (build-system copy-build-system)
+ (arguments
+ (list
+ #:install-plan
+ #~'(("FluentDark-solid" "share/fcitx5/themes/")
+ ("FluentDark" "share/fcitx5/themes/")
+ ("FluentLight-solid" "share/fcitx5/themes/")
+ ("FluentLight" "share/fcitx5/themes/"))))
+ (home-page "https://github.com/Reverier-Xu/Fluent-fcitx5")
+ (synopsis "Fluent-Design theme with blur effect and shadow for fcitx5")
+ (description
+ "Fcitx5-fluent-theme is a fluent-design theme with blur effect and
+shadow. It offers 4 versions: FluentDark, FluentDark-solid, FluentLight, and
+FluentLight-solid.")
+ (license license:mpl2.0))))