[bug#77234,1/3] Add fcitx5-catppuccin-theme

Message ID 20250324103020.5345-1-hunt31999@gmail.com
State New
Headers
Series Add three fcitx5 themes |

Commit Message

Kurome March 24, 2025, 10:30 a.m. UTC
  Change-Id: I4de778da11550067eab9cadfaba81653c77f6ca0
---
 gnu/packages/fcitx5.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
  

Patch

diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
index 99812b7556..1f9d63a203 100644
--- a/gnu/packages/fcitx5.scm
+++ b/gnu/packages/fcitx5.scm
@@ -5,6 +5,7 @@ 
 ;;; Copyright © 2022 dan <i@dan.games>
 ;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2024 Charles <charles@charje.net>
+;;; Copyright © 2025 Kurome <hunt31999@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -617,3 +618,32 @@  (define-public fcitx5-rime
 and sentences intelligently and provide very accurate traditional Chinese
 output.")
     (license license:lgpl2.1+)))
+
+(define-public fcitx5-catppuccin-theme
+  (let ((commit "383c27ac46cbb55aa5f58acbd32841c1ed3a78a0")
+        (revision "0"))
+    (package
+      (name "fcitx5-catppuccin-theme")
+      (version (git-version "0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/catppuccin/fcitx5")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "07l5d1nlwiq2jhydxckv7a44kic1y8jl93q0jr2i0lmq0zvdzkcz"))))
+      (build-system copy-build-system)
+      (arguments
+       (list
+        #:install-plan
+        #~'(("src" "share/fcitx5/themes"))))
+      (home-page "https://github.com/catppuccin/fcitx5")
+      (synopsis "Soothing pastel theme for Fcitx5")
+      (description
+       "Fcitx5-catppuccin-theme is a soothing pastel theme for Fcitx 5.  It
+provides 4 flavors (latte, frappe, macchiato and mocha) and 14 accent colors
+(rosewater, flamingo, pink, mauve, red, maroon, peach, yellow, green, teal, sky,
+sapphire, blue and lavender).")
+      (license license:expat))))