[bug#77218] gnu: emacs-eros: Update to 0.1.0.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-eros): Update to 0.1.0, synopsis reworded.
Change-Id: I6e3c9f787a2fc47f20fe39477b0d10ed47d71f93
---
I've written for this email subject and commit message that I've updated
emacs-eros to 0.1.0, though what I found in fact was that the upstream source
had always read `Version: 0.1.0' in `eros.el' despite the previous revisions of
this Guix package using 0.0.1. Unless I've assumed wrongly I thought that the
convention with un-tagged or un-released upstreams is that the version is taken
from the top-level Elisp source. No worries if this is not the case.
I've updated the package to use the most recent commit also. In testing I
couldn't see anywhere it had broken dependents, though I'd hope any breaking
change upstream would necessitate a version bump.
gnu/packages/emacs-xyz.scm | 14 ++++++++------
1 file changed, 8 insertions(+), 6 deletions(-)
Comments
Looks good to me, thanks for the patch !
> In testing I couldn't see anywhere it had broken dependents, though I'd
> hope any breaking change upstream would necessitate a version bump.
You may use ‘guix refresh -l’ and ‘guix build --dependents’ to check for
other packages impacted by your changes, before submitting.
Could you include the no tests flag to comply with upcoming changes in
emacs packages ?
(arguments
;; no tests
(list #:tests? #false))
C.
Cayetano Santos <csantosb@inventati.org> writes:
> Looks good to me, thanks for the patch !
> ...
> You may use ‘guix refresh -l’ and ‘guix build --dependents’ to check for
> other packages impacted by your changes, before submitting.
Checked both these, all looks fine.
> Could you include the no tests flag to comply with upcoming changes in
> emacs packages ?
Done and sorted, v2 patch now sent in, thanks
@@ -155,6 +155,7 @@
;;; Copyright © 2025 Remco van 't Veer <remco@remworks.net>
;;; Copyright © 2025 Skylar Hill <stellarskylark@posteo.net>
;;; Copyright © 2025 Cayetano Santos <csantosb@inventati.org>
+;;; Copyright © 2025 Lee Thompson <lee.p.thomp@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28763,11 +28764,12 @@ (define-public emacs-sml-mode
(license license:gpl3+)))
(define-public emacs-eros
- (let ((commit "dd8910279226259e100dab798b073a52f9b4233a")
- (revision "2"))
+ (let ((commit "a9a92bdc6be0521a6a06eb464be55ed61946639c")
+ (revision "0"))
(package
(name "emacs-eros")
- (version (git-version "0.0.1" revision commit))
+ ;; No tag or release, version taken from `eros.el'.
+ (version (git-version "0.1.0" revision commit))
(source
(origin
(method git-fetch)
@@ -28776,12 +28778,12 @@ (define-public emacs-eros
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32
- "08chj3a0lw4ygi2sv7wj0i6ihfbi8jhylr8p92inif8b88r6wg3k"))))
+ (base32 "04nkqsvh8c988hc3ajigs206ad64204qdhhqzdvm3k7m7qiiwga8"))))
(build-system emacs-build-system)
(home-page "https://github.com/xiongtx/eros")
(synopsis "Evaluation result overlays")
- (description "@code{eros} provides evaluation result overlays.")
+ (description "@code{eros} provides result overlays for evaluating Emacs
+Lisp.")
(license license:gpl3+))))
(define-public emacs-geiser-eros