[bug#77216] gnu: Add font-apl385 and font-apl333.

Message ID 20250323184409.30052-1-lee.p.thomp@gmail.com
State New
Headers
Series [bug#77216] gnu: Add font-apl385 and font-apl333. |

Commit Message

Lee Thompson March 23, 2025, 6:42 p.m. UTC
  * gnu/packages/fonts.scm (font-apl385, font-apl333): New variables.

Change-Id: I95366f8dccf37787db7abbf09191d9a29d6d7e33
---
 gnu/packages/fonts.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)
  

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 3048289ac0..6743d6d717 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -64,6 +64,7 @@ 
 ;;; Copyright © 2025 Ashish SHUKLA <ashish.is@lostca.se>
 ;;; Copyright © 2024 Josep Bigorra <jjbigorra@gmail.com>
 ;;; Copyright © 2023 Santiago Payà Miralta <santiagopim@gmail.com>
+;;; Copyright © 2025 Lee Thompson <lee.p.thomp@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4268,3 +4269,41 @@  (define-public font-cica
 In addition, Nerd Fonts, Noto Emoji, Icons for Devs, and some adjustment forked
 from the Ricty generator are converted and adjusted.")
     (license license:silofl1.1)))
+
+(define-public font-apl385
+  (package
+    (name "font-apl385")
+    ;; No version number or release, unzipping source and checking file times
+    ;; shows the font file was last modified on 2016-08-21.
+    (version "20160821")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://apl385.com/fonts/" "apl385.zip"))
+       (sha256
+        (base32 "132qfsnx0v6qf8x8iy3flivv449nz42nnpkwjysmz65w6wqxpk1g"))))
+    (build-system font-build-system)
+    (home-page "https://apl385.com/fonts/index.htm")
+    (synopsis "Monospaced APL font inspired by Comic Sans Serif")
+    (description
+     "Adrian Smith's monospaced APL font developed with APL software vendors
+in the late 1980s.")
+    (license license:public-domain)))
+
+(define-public font-apl333
+  (package
+    (inherit font-apl385)
+    (name "font-apl333")
+    ;; Version number as for apl-385, last modified 2013-04-20.
+    (version "20130420")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://apl385.com/fonts/" "apl333.zip"))
+       (sha256
+        (base32 "0yn0ha7d14vp4ma3lxbc9kpyrn20m7brjisr6w55c9mi24w9v3a5"))))
+    (synopsis "Variable-width APL font inspired by Comic Sans Serif")
+    (description
+     "Variable-width version of Adrian Smith's APL385 font developed with APL
+software vendors in the late 1980s.")
+    (license license:public-domain)))