[bug#77192] gnu: Add font-apl386.
Commit Message
* gnu/packages/fonts.scm (font-apl386): New variable.
Change-Id: If29a528547e1d6153ac95f0bd0d17367db256d99
---
gnu/packages/fonts.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)
Comments
I've sent over a v2 patch with updated synopsis after working at
packaging the APL385 font as well. I think this is less ambiguous and
would make more sense when both are packaged.
@@ -64,6 +64,7 @@
;;; Copyright © 2025 Ashish SHUKLA <ashish.is@lostca.se>
;;; Copyright © 2024 Josep Bigorra <jjbigorra@gmail.com>
;;; Copyright © 2023 Santiago Payà Miralta <santiagopim@gmail.com>
+;;; Copyright © 2025 Lee Thompson <lee.p.thomp@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4268,3 +4269,32 @@ (define-public font-cica
In addition, Nerd Fonts, Noto Emoji, Icons for Devs, and some adjustment forked
from the Ricty generator are converted and adjusted.")
(license license:silofl1.1)))
+
+(define-public font-apl386
+ ;; No tags or formal releases upstream
+ (let ((commit "c5bca014b6610ee170985c3ce32a8bb14dbd7b94")
+ (revision "0")
+ (version "0"))
+ (package
+ (name "font-apl386")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/abrudz/APL386")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0z7kpqgfrb053rajnr08n02rdwg5w1aynxj13ys93j0k3xvv5a75"))
+ ;; Delete APL385 copy used for web page comparisons
+ (snippet
+ '(delete-file "APL385.ttf"))))
+ (build-system font-build-system)
+ (home-page "https://abrudz.github.io/APL386/")
+ (synopsis "APL Unicode font inspired by Comic Sans Serif")
+ (description
+ "Evolution of Adrian Smith's APL385 font with a fun, whimsical look,
+inspired by Comic Sans Serif. Every special character used by any APL
+implementation is supported.")
+ (license license:unlicense))))