[bug#77191] gnu: Add font-bqn386
Commit Message
* gnu/packages/fonts.scm: (font-bqn386): New variable
Change-Id: I8c39021142416d268464dbdd46327871e9fd977a
---
gnu/packages/fonts.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)
Comments
Apologies all, after working at packaging the APL386 and APL385 fonts I
decided to reword this synopsis to mention 386.
@@ -64,6 +64,7 @@
;;; Copyright © 2025 Ashish SHUKLA <ashish.is@lostca.se>
;;; Copyright © 2024 Josep Bigorra <jjbigorra@gmail.com>
;;; Copyright © 2023 Santiago Payà Miralta <santiagopim@gmail.com>
+;;; Copyright © 2025 Lee Thompson <lee.p.thomp@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4268,3 +4269,29 @@ (define-public font-cica
In addition, Nerd Fonts, Noto Emoji, Icons for Devs, and some adjustment forked
from the Ricty generator are converted and adjusted.")
(license license:silofl1.1)))
+
+(define-public font-bqn386
+ ;; No tags or formal releases upstream
+ (let ((commit "90ef32ea18ab44786d67625971145db6f0dc165f")
+ (revision "0")
+ (version "0"))
+ (package
+ (name "font-bqn386")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dzaima/BQN386")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0cqhgcda6akgrm0i4sjaxx7jg1m7388nyggcxz15bpp9bnh5igrn"))))
+ (build-system font-build-system)
+ (home-page "https://dzaima.github.io/BQN386/")
+ (synopsis "BQN and APL font")
+ (description
+ "An APL and BQN font extending APL386 by Adám Brudzewsky, which is
+based on APL385 by Adrian Smith. The entire BQN character set is included
+along with some APL characters that don't feature in BQN.")
+ (license license:unlicense))))