[bug#73760,v2] gnu: googlebenchmark: Upgrade to v1.9.1.

Message ID 20250321172542.73122-1-aarcov@gmail.com
State New
Headers
Series [bug#73760,v2] gnu: googlebenchmark: Upgrade to v1.9.1. |

Commit Message

Aaron Covrig March 21, 2025, 5:25 p.m. UTC
  From: Aaron Covrig <aaron.covrig.us@ieee.org>

* gnu/packages/check.scm (googlebenchmark): Upgrade to 1.9.1.
---
 gnu/packages/check.scm | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)


base-commit: efac1498c15198afc4f9a2bc700408bde1b3b3ed
  

Comments

Greg Hogan March 21, 2025, 7:45 p.m. UTC | #1
On Fri, Mar 21, 2025 at 1:26 PM Aaron Covrig via Guix-patches via
<guix-patches@gnu.org> wrote:
>
> From: Aaron Covrig <aaron.covrig.us@ieee.org>
>
> * gnu/packages/check.scm (googlebenchmark): Upgrade to 1.9.1.
> ---
>  gnu/packages/check.scm | 7 +++----
>  1 file changed, 3 insertions(+), 4 deletions(-)
>
> diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
> index 4994a10f11..38c10c91be 100644
> --- a/gnu/packages/check.scm
> +++ b/gnu/packages/check.scm
> @@ -1104,7 +1104,7 @@ (define-public googletest-1.8
>  (define-public googlebenchmark
>    (package
>      (name "googlebenchmark")
> -    (version "1.8.3")
> +    (version "1.9.1")
>      (home-page "https://github.com/google/benchmark")
>      (source (origin
>                (method git-fetch)
> @@ -1113,15 +1113,14 @@ (define-public googlebenchmark
>                (file-name (git-file-name "google-benchmark" version))
>                (sha256
>                 (base32
> -                "1hf8xrdd9k57kw3mpdi68a78fd96vzdqv3179v2yy5dxx336ffw3"))))
> +                "1ky51j4hbqcaxp7i7sfiyh1435mgyijgbfgc48bbmi52vgay0477"))))
>      (build-system cmake-build-system)
>      (arguments
>       '(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON"
>                                 (string-append
>                                  "-DGOOGLETEST_PATH="
>                                  (assoc-ref %build-inputs "googletest")))))
> -    (inputs
> -     `(("googletest" ,(package-source googletest))))
> +    (inputs `(("googletest" ,(package-source googletest))))
>      (synopsis "C++ library to support the benchmarking of functions")
>      (description
>       "The googlebenchmark C++ library support the benchmarking of functions,
>
> base-commit: efac1498c15198afc4f9a2bc700408bde1b3b3ed
> --
> 2.48.1

Pushed as 5bf7d80535720077aec104a9904480d08b9b4f2b.
  

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 4994a10f11..38c10c91be 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1104,7 +1104,7 @@  (define-public googletest-1.8
 (define-public googlebenchmark
   (package
     (name "googlebenchmark")
-    (version "1.8.3")
+    (version "1.9.1")
     (home-page "https://github.com/google/benchmark")
     (source (origin
               (method git-fetch)
@@ -1113,15 +1113,14 @@  (define-public googlebenchmark
               (file-name (git-file-name "google-benchmark" version))
               (sha256
                (base32
-                "1hf8xrdd9k57kw3mpdi68a78fd96vzdqv3179v2yy5dxx336ffw3"))))
+                "1ky51j4hbqcaxp7i7sfiyh1435mgyijgbfgc48bbmi52vgay0477"))))
     (build-system cmake-build-system)
     (arguments
      '(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON"
                                (string-append
                                 "-DGOOGLETEST_PATH="
                                 (assoc-ref %build-inputs "googletest")))))
-    (inputs
-     `(("googletest" ,(package-source googletest))))
+    (inputs `(("googletest" ,(package-source googletest))))
     (synopsis "C++ library to support the benchmarking of functions")
     (description
      "The googlebenchmark C++ library support the benchmarking of functions,