[bug#77131,06/51] gnu: emacs-pcre2el: Skip failing tests.

Message ID 20250320100907.20485-6-ngraves@ngraves.fr
State New
Headers
Series [bug#77131,01/51] gnu: Add (gnu packages emacs-build) module. |

Commit Message

Nicolas Graves March 20, 2025, 10:08 a.m. UTC
  * gnu/packages/emacs-xyz.scm (emacs-pcre2el): Skip failing tests.
[arguments]: Add {test-command} and phase 'skip-failing-tests.
[native-inputs]: Add emacs-ert-runner.
---
 gnu/packages/emacs-xyz.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
  

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0f60e15d96..3f947888c7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30718,6 +30718,20 @@  (define-public emacs-pcre2el
           (base32
            "0h73d9f1zj74vjir2kiq4s2g5rai7b59z7da20kh862xnldfcxsx"))))
       (build-system emacs-build-system)
+      (arguments
+       (list
+        #:test-command #~(list "ert-runner" "-L" "." "pcre2el-tests.el")
+        #:phases
+        #~(modify-phases %standard-phases
+            (add-before 'check 'skip-failing-tests
+              (lambda _
+                (let ((unexpected (list "017" "018" "125" "584" "585" "601" "690")))
+                  (substitute* "pcre2el-tests.el"
+                    (((string-append "\\(ert-deftest rxt-pcre-test-00("
+                                     (string-join unexpected "|")
+                                     ") .*") all)
+                     (string-append all "(skip-unless nil)")))))))))
+      (native-inputs (list emacs-ert-runner))
       (home-page "https://github.com/joddie/pcre2el")
       (synopsis "Convert between PCRE, Emacs and rx regexp syntax")
       (description "@code{pcre2el} or @code{rxt} (RegeXp Translator or RegeXp