[bug#77131,32/51] gnu: emacs-polymode-org: Skip failing tests.

Message ID 20250320100907.20485-32-ngraves@ngraves.fr
State New
Headers
Series [bug#77131,01/51] gnu: Add (gnu packages emacs-build) module. |

Commit Message

Nicolas Graves March 20, 2025, 10:08 a.m. UTC
  * gnu/packages/emacs-xyz.scm (emacs-polymode-org)
[arguments]{test-command}: Set it.
{phases}: Add phase 'patch-tests to skip failing tests.
---
 gnu/packages/emacs-xyz.scm | 11 +++++++++++
 1 file changed, 11 insertions(+)
  

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 80bab56b15..82b8c8e009 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23920,6 +23920,17 @@  (define-public emacs-polymode-org
        (sha256
         (base32 "1srnwcsn2bh8gqzxixkhffk7gbnk66kd4dgvxbnps5nxqc6v0qhc"))))
     (build-system emacs-build-system)
+    (arguments
+     (list
+      #:test-command #~(list "make" "test")
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'check 'patch-tests
+            (lambda _
+              (substitute* "tests/poly-org-tests.el"
+                (("\\(ert-deftest poly-org/change-spans \\(\\)"
+                  all)
+                 (string-append all "(skip-unless nil)"))))))))
     (propagated-inputs
      (list emacs-polymode))
     (properties '((upstream-name . "poly-org")))