* gnu/packages/crates-io.scm (rust-rustyline-15): New variable.
---
gnu/packages/crates-io.scm | 56 +++++++++++++++++++++++++++++++++-----
1 file changed, 49 insertions(+), 7 deletions(-)
@@ -68738,8 +68738,56 @@ (define-public rust-rusty-fork-0.2
("rust-tempfile" ,rust-tempfile-3)
("rust-wait-timeout" ,rust-wait-timeout-0.2))))))
+(define-public rust-rustyline-15
+ (package
+ (name "rust-rustyline")
+ (version "15.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rustyline" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0bws18zrj8i6ix27k9bhb3mb1civbz5nr72rv8xm2bljvikf1q9f"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(;#:cargo-test-flags '("--release" "--"
+ ; "--skip=binding::test::size_of_event")
+ #:cargo-inputs (("rust-bitflags" ,rust-bitflags-2)
+ ("rust-buffer-redux" ,rust-buffer-redux-1)
+ ("rust-cfg-if" ,rust-cfg-if-1)
+ ("rust-clipboard-win" ,rust-clipboard-win-5)
+ ("rust-fd-lock" ,rust-fd-lock-4)
+ ("rust-home" ,rust-home-0.5)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-memchr" ,rust-memchr-2)
+ ("rust-nix" ,rust-nix-0.29)
+ ("rust-radix-trie" ,rust-radix-trie-0.2)
+ ("rust-regex" ,rust-regex-1)
+ ("rust-rusqlite" ,rust-rusqlite-0.32)
+ ("rust-rustyline-derive" ,rust-rustyline-derive-0.11)
+ ("rust-signal-hook" ,rust-signal-hook-0.3)
+ ("rust-skim" ,rust-skim-0.10)
+ ("rust-termios" ,rust-termios-0.3)
+ ("rust-unicode-segmentation" ,rust-unicode-segmentation-1)
+ ("rust-unicode-width" ,rust-unicode-width-0.2)
+ ("rust-utf8parse" ,rust-utf8parse-0.2)
+ ("rust-winapi" ,rust-windows-sys-0.59))
+ #:cargo-development-inputs (("rust-assert-matches" ,rust-assert-matches-1)
+ ("rust-doc-comment" ,rust-doc-comment-0.3)
+ ("rust-env-logger" ,rust-env-logger-0.11)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-tempfile" ,rust-tempfile-3))))
+ (home-page "https://github.com/kkawakam/rustyline")
+ (synopsis "Readline implementation in Rust")
+ (description
+ "Rustyline is a readline implementation based on the linenoise package.")
+ (license license:expat)))
+
(define-public rust-rustyline-13
(package
+ (inherit rust-rustyline-15)
(name "rust-rustyline")
(version "13.0.0")
(source
@@ -68749,7 +68797,6 @@ (define-public rust-rustyline-13
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "11mywskk2jcxhanlsgzza5yx6ywpdlzr64qhbgpsx45clj1xd8h2"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-test-flags '("--release" "--"
"--skip=binding::test::size_of_event")
@@ -68777,12 +68824,7 @@ (define-public rust-rustyline-13
("rust-doc-comment" ,rust-doc-comment-0.3)
("rust-env-logger" ,rust-env-logger-0.10)
("rust-rand" ,rust-rand-0.8)
- ("rust-tempfile" ,rust-tempfile-3))))
- (home-page "https://github.com/kkawakam/rustyline")
- (synopsis "Readline implementation in Rust")
- (description
- "Rustyline is a readline implementation based on the linenoise package.")
- (license license:expat)))
+ ("rust-tempfile" ,rust-tempfile-3))))))
(define-public rust-rustyline-12
(package