[bug#76872,rust-team,v3,02/10] gnu: rust-rustyline-derive-0.11: New variable.

Message ID 20250319234237.1906210-3-aaron.covrig.us@ieee.org
State New
Headers
Series Correct broken character set |

Commit Message

Aaron Covrig March 19, 2025, 11:41 p.m. UTC
  * gnu/packages/crates-io.scm (rust-rustyline-derive-0.11): New variable.
---
 gnu/packages/crates-io.scm | 23 ++++++++++++++++++++---
 1 file changed, 20 insertions(+), 3 deletions(-)
  

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 4252c3d418..898de47b6f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -68936,17 +68936,17 @@  (define-public rust-rustyline-6
         ("rust-rustyline-derive" ,rust-rustyline-derive-0.3)
         ("rust-tempfile" ,rust-tempfile-3))))))
 
-(define-public rust-rustyline-derive-0.10
+(define-public rust-rustyline-derive-0.11
   (package
     (name "rust-rustyline-derive")
-    (version "0.10.0")
+    (version "0.11.0")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "rustyline-derive" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "0lfr25qdrn0awccq999d6g8m7bhsyxbkliibdpzimbzniff9bbz5"))))
+        (base32 "03cfnk753gfbxhp13dbcg9b0vksmxzkinksrpxgy5xvdbw3rszij"))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs (("rust-proc-macro2" ,rust-proc-macro2-1)
@@ -68957,6 +68957,23 @@  (define-public rust-rustyline-derive-0.10
     (description "This package provides Rustyline macros implementation in Rust.")
     (license license:expat)))
 
+(define-public rust-rustyline-derive-0.10
+  (package
+    (inherit rust-rustyline-derive-0.11)
+    (name "rust-rustyline-derive")
+    (version "0.10.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "rustyline-derive" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0lfr25qdrn0awccq999d6g8m7bhsyxbkliibdpzimbzniff9bbz5"))))
+    (arguments
+     `(#:cargo-inputs (("rust-proc-macro2" ,rust-proc-macro2-1)
+                       ("rust-quote" ,rust-quote-1)
+                       ("rust-syn" ,rust-syn-2))))))
+
 (define-public rust-rustyline-derive-0.9
   (package
     (inherit rust-rustyline-derive-0.10)