[bug#74743,rust-team,v2,43/68] gnu: rust-faster-hex-0.10: New variable.

Message ID 20250319011932.1899508-44-aaron.covrig.us@ieee.org
State New
Headers
Series Assorted rust-* package upgrades |

Commit Message

Aaron Covrig March 19, 2025, 1:19 a.m. UTC
  * gnu/packages/crates-io.scm (rust-faster-hex-0.10): New variable.

Signed-off-by: Aaron Covrig <aaron.covrig.us@ieee.org>
---
 gnu/packages/crates-io.scm | 35 +++++++++++++++++++++++++++++------
 1 file changed, 29 insertions(+), 6 deletions(-)
  

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 44c8f18dfc..b1d7d21484 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -25794,8 +25794,36 @@  (define-public rust-fast-float-0.2
     (description "This package provides a fast floating-point number parser.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-faster-hex-0.10
+  (package
+    (name "rust-faster-hex")
+    (version "0.10.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "faster-hex" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0wzvv4a1czxfxmh99cza2y0jps97hm3k1j6r6cs816qp5wnsw8vj"))))
+    (build-system cargo-build-system)
+    (arguments
+      (list #:cargo-inputs (list rust-heapless-0.8 rust-serde-1)
+            #:cargo-development-inputs
+            (list rust-bytes-1
+                  rust-criterion-0.5
+                  rust-hex-0.3
+                  rust-proptest-1
+                  rust-rustc-hex-1
+                  rust-serde-1
+                  rust-serde-json-1)))
+    (home-page "https://github.com/NervosFoundation/faster-hex")
+    (synopsis "Fast hex encoding")
+    (description "Fast hex encoding.")
+    (license license:expat)))
+
 (define-public rust-faster-hex-0.9
   (package
+    (inherit rust-faster-hex-0.10)
     (name "rust-faster-hex")
     (version "0.9.0")
     (source
@@ -25805,7 +25833,6 @@  (define-public rust-faster-hex-0.9
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "10wi4vqbdpkamw4qvra1ijp4as2j7j1zc66g4rdr6h0xv8gb38m2"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs (("rust-serde" ,rust-serde-1))
        #:cargo-development-inputs (("rust-bytes" ,rust-bytes-1)
@@ -25814,11 +25841,7 @@  (define-public rust-faster-hex-0.9
                                    ("rust-proptest" ,rust-proptest-1)
                                    ("rust-rustc-hex" ,rust-rustc-hex-1)
                                    ("rust-serde" ,rust-serde-1)
-                                   ("rust-serde-json" ,rust-serde-json-1))))
-    (home-page "https://github.com/NervosFoundation/faster-hex")
-    (synopsis "Fast hex encoding")
-    (description "Fast hex encoding.")
-    (license license:expat)))
+                                   ("rust-serde-json" ,rust-serde-json-1))))))
 
 (define-public rust-faster-hex-0.8
   (package