* gnu/packages/crates-io.scm (rust-rand-0.9): New variable.
Signed-off-by: Aaron Covrig <aaron.covrig.us@ieee.org>
---
gnu/packages/crates-io.scm | 40 ++++++++++++++++++++++++++++++--------
1 file changed, 32 insertions(+), 8 deletions(-)
@@ -62246,8 +62246,39 @@ (define-public rust-railroad-verification-0.1
@code{railroad}.")
(license license:expat)))
+(define-public rust-rand-0.9
+ (package
+ (name "rust-rand")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rand" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "156dyvsfa6fjnv6nx5vzczay1scy5183dvjchd7bvs47xd5bjy9p"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-log" ,rust-log-0.4)
+ ("rust-rand-chacha" ,rust-rand-chacha-0.9)
+ ("rust-rand-core" ,rust-rand-core-0.9)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-zerocopy" ,rust-zerocopy-0.8))
+ #:cargo-development-inputs
+ (("rust-bincode" ,rust-bincode-1)
+ ("rust-rand-pcg" ,rust-rand-pcg-0.9)
+ ("rust-rand-pcg" ,rust-rayon-1))))
+ (home-page "https://rust-random.github.io/book")
+ (synopsis "Random number generators and other randomness functionality")
+ (description
+ "Rand provides utilities to generate random numbers, to convert them to
+useful types and distributions, and some randomness-related algorithms.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-rand-0.8
(package
+ (inherit rust-rand-0.9)
(name "rust-rand")
(version "0.8.5")
(source
@@ -62257,7 +62288,6 @@ (define-public rust-rand-0.8
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "013l6931nn7gkc23jz5mm3qdhf93jjf0fg64nz2lp4i51qd8vbrl"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-libc" ,rust-libc-0.2)
@@ -62268,13 +62298,7 @@ (define-public rust-rand-0.8
("rust-serde" ,rust-serde-1))
#:cargo-development-inputs
(("rust-bincode" ,rust-bincode-1)
- ("rust-rand-pcg" ,rust-rand-pcg-0.3))))
- (home-page "https://crates.io/crates/rand")
- (synopsis "Random number generators and other randomness functionality")
- (description
- "Rand provides utilities to generate random numbers, to convert them to
-useful types and distributions, and some randomness-related algorithms.")
- (license (list license:expat license:asl2.0))))
+ ("rust-rand-pcg" ,rust-rand-pcg-0.3))))))
(define-public rust-rand-0.7
(package