[bug#77040,v2,20/20] gnu: Add pay-respects.

Message ID 20250315233915.744-21-gabrielsantosdesouza@disroot.org
State New
Headers
Series Add pay-respects. |

Commit Message

Gabriel Santos March 15, 2025, 11:28 p.m. UTC
  * gnu/packages/rust-apps.scm (pay-respects): New variable.

Change-Id: I67747564c958b98ad52b02dd49ccf64d17510553
---
 gnu/packages/rust-apps.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
  

Patch

diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 2f933d836c..6ec81351fb 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -35,6 +35,7 @@ 
 ;;; Copyright © 2024 normally_js <normally_js@posteo.net>
 ;;; Copyright © 2025 Divya Ranjan Pattanaik <divya@subvertising.org>
 ;;; Copyright © 2025 Andrew Wong <wongandj@icloud.com>
+;;; Copyright © 2025 Gabriel Santos <gabrielsantosdesouza@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4975,3 +4976,32 @@  (define-public podlet
      "This package generates Podman Quadlet files from a Podman command,
 compose file, or existing object.")
     (license license:mpl2.0)))
+
+(define-public pay-respects
+  (package
+    (name "pay-respects")
+    (version "0.6.14")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "pay-respects" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0g3vsp6xyw5isr7l10mbljvdclh2s3cmpm7sqxf5a8ir9mfmvkz2"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:install-source? #f
+       #:cargo-inputs (("rust-colored" ,rust-colored-3)
+                       ("rust-inquire" ,rust-inquire-0.7)
+                       ("rust-pay-respects-parser" ,rust-pay-respects-parser-0.3)
+                       ("rust-pay-respects-utils" ,rust-pay-respects-utils-0.1)
+                       ("rust-regex-lite" ,rust-regex-lite-0.1)
+                       ("rust-rust-i18n" ,rust-rust-i18n-3)
+                       ("rust-sys-locale" ,rust-sys-locale-0.3))))
+    (home-page "https://codeberg.org/iff/pay-respects")
+    (synopsis
+     "Correct mistyped console command by pressing f")
+    (description
+     "Pay Respects suggests fixes for wrong commands when the user
+inputs f after a mistake.")
+    (license license:agpl3+)))