[bug#77040,v2,16/20] gnu: Add rust-rust-i18n-3.

Message ID 20250315233915.744-17-gabrielsantosdesouza@disroot.org
State New
Headers
Series Add pay-respects. |

Commit Message

Gabriel Santos March 15, 2025, 11:28 p.m. UTC
  * gnu/packages/crates-io.scm (rust-rust-i18n-3): New variable.

Change-Id: I1f2054a029f14b856c8083343ca0955e2794e982
---
 gnu/packages/crates-io.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
  

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a1897f2427..264f02bdfc 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -88771,6 +88771,33 @@  (define-public rust-rust-i18n-macro-3
     (description "Macro for the rust-i18n crate.")
     (license license:expat)))
 
+(define-public rust-rust-i18n-3
+  (package
+    (name "rust-rust-i18n")
+    (version "3.1.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "rust-i18n" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "16ysdz9ppinmzf6cgy8h4mc3ksxhd0qfm3l6dp47fnsnqvhsdcvi"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-globwalk" ,rust-globwalk-0.8)
+                       ("rust-once-cell" ,rust-once-cell-1)
+                       ("rust-regex" ,rust-regex-1)
+                       ("rust-rust-i18n-macro" ,rust-rust-i18n-macro-3)
+                       ("rust-rust-i18n-support" ,rust-rust-i18n-support-3)
+                       ("rust-smallvec" ,rust-smallvec-1))))
+    (home-page "https://github.com/longbridge/rust-i18n")
+    (synopsis
+     "Simple i18n crate for text localization")
+    (description
+     "This package provides a simple and easy-to-use API for
+localizing text.")
+    (license license:expat)))
+
 (define-public rust-unic-char-property-0.9
   (package
     (name "rust-unic-char-property")