[bug#77040,v2,15/20] gnu: Add rust-rust-i18n-macro-3.

Message ID 20250315233915.744-16-gabrielsantosdesouza@disroot.org
State New
Headers
Series Add pay-respects. |

Commit Message

Gabriel Santos March 15, 2025, 11:28 p.m. UTC
  * gnu/packages/crates-io.scm (rust-rust-i18n-macro-3): New variable.

Change-Id: I46bc498eb354a25f4efa5ca5c60a3d87bbc69531
---
 gnu/packages/crates-io.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
  

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 40c45cf23e..a1897f2427 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -88743,6 +88743,34 @@  (define-public rust-rust-i18n-support-3
     (description "Support for the rust-i18n crate.")
     (license license:expat)))
 
+(define-public rust-rust-i18n-macro-3
+  (package
+    (name "rust-rust-i18n-macro")
+    (version "3.1.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "rust-i18n-macro" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0xc2j998r9rcbynfzdgjjjk3d0v72mnzrdzaq7zqbd7jd98di031"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-test-flags '("--lib")
+       #:cargo-inputs (("rust-glob" ,rust-glob-0.3)
+                       ("rust-once-cell" ,rust-once-cell-1)
+                       ("rust-proc-macro2" ,rust-proc-macro2-1)
+                       ("rust-quote" ,rust-quote-1)
+                       ("rust-rust-i18n-support" ,rust-rust-i18n-support-3)
+                       ("rust-serde" ,rust-serde-1)
+                       ("rust-serde-json" ,rust-serde-json-1)
+                       ("rust-serde-yml" ,rust-serde-yml-0.0.12)
+                       ("rust-syn" ,rust-syn-2))))
+    (home-page "https://github.com/longbridge/rust-i18n")
+    (synopsis "Macro for the rust-i18n crate")
+    (description "Macro for the rust-i18n crate.")
+    (license license:expat)))
+
 (define-public rust-unic-char-property-0.9
   (package
     (name "rust-unic-char-property")