[bug#77040,v2,10/20] gnu: Add rust-base62-2.
Commit Message
* gnu/packages/crates-io.scm (rust-base62-2): New variable.
Change-Id: Ia9db81804484a1b13ade230d21229f54cd78b336
---
gnu/packages/crates-io.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
@@ -6683,6 +6683,27 @@ (define-public rust-base58-0.1
c6e7d37. However, this package works only up to 128 bytes.")
(license license:expat)))
+(define-public rust-base62-2
+ (package
+ (name "rust-base62")
+ (version "2.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "base62" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "07xb6xj6f3h46kjhjj8sxnkvgjz3z4x0bd8zwazfwsqxrdxjmr8h"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-rustversion" ,rust-rustversion-1)
+ ("rust-criterion" ,rust-criterion-0.5))))
+ (home-page "https://github.com/fbernier/base62")
+ (synopsis "Encode and decode base62")
+ (description "Thus package provides tools for working with base62
+in Rust. Base62 is usually used for URLs.")
+ (license license:expat)))
+
(define-public rust-base64-0.22
(package
(name "rust-base64")