[bug#77040,1/7] gnu: Add rust-colored-3.

Message ID 20250315184209.4188-1-gabrielsantosdesouza@disroot.org
State New
Headers
Series gnu: Add pay-respects. |

Commit Message

Gabriel Santos March 15, 2025, 6:41 p.m. UTC
  * gnu/packages/crates-io.scm (rust-colored-3): New variable.

Change-Id: Ie78a8701fb294f8d582eb3a6865d1a7d0772b9ad
---
 gnu/packages/crates-io.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
  

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 71cb868b4d..01f8810207 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -50,6 +50,7 @@ 
 ;;; Copyright © 2025 Divya Ranjan Pattanaik <divya@subvertising.org>
 ;;; Copyright © 2025 Karl Hallsby <karl@hallsby.com>
 ;;; Copyright © 2025 Andrew Wong <wongandj@icloud.com>
+;;; Copyright © 2025 Gabriel Santos <gabrielsantosdesouza@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -13989,6 +13990,30 @@  (define-public rust-colorchoice-1
     (description "Global override of color control")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-colored-3
+  (package
+    (name "rust-colored")
+    (version "3.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "colored" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0plizddhxc4vgkzdbzky5zggyaqfrmyim2d0n6sb7py9j3nf1q7x"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:tests? #f       ; Tests expect a real terminal.
+       #:cargo-inputs (("rust-windows-sys" ,rust-windows-sys-0.59)
+                       ("rust-ansi-term" ,rust-ansi-term-0.12)
+                       ("rust-insta" ,rust-insta-1.42.2)
+                       ("rust-rspec" ,rust-rspec-1))))
+    (home-page "https://github.com/mackwic/colored")
+    (synopsis "Add colors in your terminal")
+    (description
+     "The most simple way to add colors in your terminal.")
+    (license license:mpl2.0)))
+
 (define-public rust-colored-2
   (package
     (name "rust-colored")