[bug#76835,v3,05/40] gnu: python-h2: Fix test-flags.

Message ID 20250310021652.17530-5-ngraves@ngraves.fr
State New
Headers
Series [bug#76835,v3,01/40] gnu: gunicorn: Migrate 'check phase to pyproject-build-system. |

Commit Message

Nicolas Graves March 10, 2025, 2:16 a.m. UTC
  * gnu/packages/python-web.scm (python-h2)[arguments]{test-flags}:
Fix quoting.
---
 gnu/packages/python-web.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
  

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 4765ab2358..2438fba134 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2483,9 +2483,9 @@  (define-public python-h2
               (string-join
                (list "not test_remotesettingschanged_repr"
                      ;; This test exceededs the Hypothesis deadline.
-                     ,@(if (target-riscv64?)
-                           `("test_changing_max_frame_size")
-                           '())
+                     #$@(if (target-riscv64?)
+                            #~("test_changing_max_frame_size")
+                            #~())
                      "test_streamreset_repr"
                      "test_settingsacknowledged_repr"
                      "test_connectionterminated_repr[None-None]"