[bug#76835,v3,40/40] gnu: Remove snakemake.

Message ID 20250310021652.17530-40-ngraves@ngraves.fr
State New
Headers
Series [bug#76835,v3,01/40] gnu: gunicorn: Migrate 'check phase to pyproject-build-system. |

Commit Message

Nicolas Graves March 10, 2025, 2:16 a.m. UTC
  * gnu/packages/python-xyz.scm (snakemake): Delete variable.
---
 gnu/packages/python-xyz.scm | 84 -------------------------------------
 1 file changed, 84 deletions(-)
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fa73a189ce..91c662c35c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14915,90 +14915,6 @@  (define-public python-throttler
 throttling with asyncio support.")
     (license license:expat)))
 
-(define-public snakemake
-  (package
-    (name "snakemake")
-    (version "5.32.2")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/snakemake/snakemake")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0nxp4z81vykv07kv2b6zrwk7ns8s10zqsb7vcignp8695yq3nlcm"))))
-    (build-system pyproject-build-system)
-    (arguments
-     (list
-      #:test-flags
-      '(list
-        ;; We have no TES support.
-        "--ignore=tests/test_tes.py"
-        ;; This test attempts to change S3 buckets on AWS and fails
-        ;; because there are no AWS credentials.
-        "--ignore=tests/test_tibanna.py"
-        ;; It's a similar story with this test, which requires access
-        ;; to the Google Storage service.
-        "--ignore=tests/test_google_lifesciences.py")
-      #:phases
-      #~(modify-phases %standard-phases
-          (add-after 'unpack 'tabulate-compatibility
-            (lambda _
-              (substitute* "snakemake/dag.py"
-                (("\"job\": rule,")
-                 "\"job\": rule.name,"))))
-          (add-after 'unpack 'patch-version
-            (lambda _
-              (substitute* "setup.py"
-                (("version=versioneer.get_version\\(\\)")
-                 (format #f "version=~s" #$version)))
-              (substitute* '("snakemake/_version.py"
-                             "versioneer.py")
-                (("0\\+unknown") #$version))))
-          ;; For cluster execution Snakemake will call Python.  Since there is
-          ;; no suitable PYTHONPATH set, cluster execution will fail.  We fix
-          ;; this by calling the snakemake wrapper instead.
-          (add-after 'unpack 'call-wrapper-not-wrapped-snakemake
-            (lambda _
-              (substitute* "snakemake/executors/__init__.py"
-                (("\\{sys.executable\\} -m snakemake")
-                 (string-append #$output "/bin/snakemake")))))
-          (add-before 'check 'pre-check
-            (lambda _ (setenv "HOME" "/tmp"))))))
-    (propagated-inputs
-     (list python-appdirs
-           python-configargparse
-           python-datrie
-           python-docutils
-           python-gitpython
-           python-jinja2
-           python-jsonschema
-           python-nbformat
-           python-networkx
-           python-psutil
-           python-pulp
-           python-pyyaml
-           python-ratelimiter
-           python-requests
-           python-toposort
-           python-wrapt))
-    (native-inputs
-     (list git-minimal
-           python-wrapper
-           python-pytest
-           python-pandas
-           python-requests-mock
-           python-setuptools
-           python-wheel))
-    (home-page "https://snakemake.readthedocs.io")
-    (synopsis "Python-based execution environment for make-like workflows")
-    (description
-      "Snakemake aims to reduce the complexity of creating workflows by
-providing a clean and modern domain specific specification language (DSL) in
-Python style, together with a fast and comfortable execution environment.")
-    (license license:expat)))
-
 (define-public python-pyqrcode
   (package
     (name "python-pyqrcode")