[bug#76835,v3,35/40] gnu: Add python-conda-inject.
Commit Message
* gnu/packages/package-management.scm (python-conda-inject): New variable.
---
gnu/packages/package-management.scm | 32 +++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)
@@ -1123,6 +1123,38 @@ (define-public python-anaconda-client
environments.")
(license license:bsd-3)))
+(define-public python-conda-inject
+ (package
+ (name "python-conda-inject")
+ (version "1.3.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/koesterlab/conda-inject")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1aig9l676wc2sjb20y7rdqf0hfcfjhh92yfiy82mf7kfnv7rp3rk"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python3" "tests/tests.py")))))))
+ (propagated-inputs (list python-pyyaml))
+ (native-inputs (list python-poetry-core python-pytest))
+ (home-page "https://github.com/koesterlab/conda-inject")
+ (synopsis
+ "Inject a conda environment into the current python environment")
+ (description
+ "This package provides helper functions for injecting a conda
+environment into the current python environment (by modifying @code{sys.path},
+without actually changing the current python environment).")
+ (license license:expat)))
+
(define-public python-conda-package-handling
(package
(name "python-conda-package-handling")