[bug#76835,v3,34/40] gnu: Add python-reretry.

Message ID 20250310021652.17530-34-ngraves@ngraves.fr
State New
Headers
Series [bug#76835,v3,01/40] gnu: gunicorn: Migrate 'check phase to pyproject-build-system. |

Commit Message

Nicolas Graves March 10, 2025, 2:16 a.m. UTC
  * gnu/packages/python-xyz.scm (python-reretry): New variable.
---
 gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 540ea1b379..a12edc7ab0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7895,6 +7895,25 @@  (define-public python-repoze-lru
      "This package provides a tiny LRU cache implementation and decorator.")
     (license license:bsd-4)))
 
+(define-public python-reretry
+  (package
+    (name "python-reretry")
+    (version "0.11.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "reretry" version))
+       (sha256
+        (base32 "1qrjsjzah8gw1bciqn8bhrj80fjjg13qg8jks7qs4bjipv71yygj"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-setuptools python-wheel))
+    (home-page "https://github.com/leshchenko1979/reretry")
+    (synopsis "Python decorator for retrying on exceptions")
+    (description
+     "This provides an easy to use, but functional decorator for retrying on
+exceptions.")
+    (license license:asl2.0)))
+
 (define-public python-restructuredtext-lint
   (package
     (name "python-restructuredtext-lint")