[bug#76835,v3,31/40] gnu: Add python-snakemake-interface-software-deployment-plugins.

Message ID 20250310021652.17530-31-ngraves@ngraves.fr
State New
Headers
Series [bug#76835,v3,01/40] gnu: gunicorn: Migrate 'check phase to pyproject-build-system. |

Commit Message

Nicolas Graves March 10, 2025, 2:16 a.m. UTC
  * gnu/packages/python-science.scm
(python-snakemake-interface-software-deployment-plugins): New variable.
---
 gnu/packages/python-science.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
  

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 41ce2a3689..3ac753f55e 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1028,6 +1028,38 @@  (define-public python-snakemake-interface-report-plugins
 between Snakemake and its report plugins.")
     (license license:expat)))
 
+(define-public python-snakemake-interface-software-deployment-plugins
+  (package
+    (name "python-snakemake-interface-software-deployment-plugins")
+    (version "0.6.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/snakemake/snakemake-interface-software-deployment-plugins")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0b4kkznfyfck9f92pkimhyl13ljisfn67rsilm1a5inq2ywpmxba"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     (invoke "python3" "tests/tests.py")))))))
+    (propagated-inputs (list python-argparse-dataclass
+                             python-snakemake-interface-common))
+    (native-inputs (list python-poetry-core))
+    (home-page "\
+https://github.com/snakemake/snakemake-interface-software-deployment-plugins")
+    (synopsis "Interface for Snakemake software deployment plugins")
+    (description
+     "This package provides a stable interface for interactions between Snakemake and
+its software deployment plugins.")
+    (license license:expat)))
+
 (define-public python-tdda
   (package
     (name "python-tdda")