[bug#76835,v3,30/40] gnu: Add python-snakemake-interface-report-plugins.
Commit Message
* gnu/packages/python-science.scm
(python-snakemake-interface-report-plugins): New variable.
---
gnu/packages/python-science.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)
@@ -996,6 +996,38 @@ (define-public python-snakemake-interface-executor-plugins
its executor plugins.")
(license license:expat)))
+(define-public python-snakemake-interface-report-plugins
+ (package
+ (name "python-snakemake-interface-report-plugins")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "\
+https://github.com/snakemake/snakemake-interface-report-plugins")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0i6z9vk6nv2m3jsym0glrb7h9isdlfza2yq14vbqcslybdi9ykfa"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f ;XXX: Circular dependency on snakemake
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python3" "tests/tests.py")))))))
+ (propagated-inputs (list python-snakemake-interface-common python-pytest))
+ (native-inputs (list python-poetry-core))
+ (home-page "\
+https://github.com/snakemake/python-snakemake-interface-report-plugins")
+ (synopsis "Interface for Snakemake report plugins")
+ (description "This package provides a stable interface for interactions
+between Snakemake and its report plugins.")
+ (license license:expat)))
+
(define-public python-tdda
(package
(name "python-tdda")