[bug#76835,v3,03/40] gnu: python-carbon: Update to 1.1.10.

Message ID 20250310021652.17530-3-ngraves@ngraves.fr
State New
Headers
Series [bug#76835,v3,01/40] gnu: gunicorn: Migrate 'check phase to pyproject-build-system. |

Commit Message

Nicolas Graves March 10, 2025, 2:16 a.m. UTC
  * gnu/packages/monitoring.scm (python-carbon): Update to 1.1.10.
---
 gnu/packages/monitoring.scm | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)
  

Patch

diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index 9813b5ca67..01b554d9aa 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -433,23 +433,24 @@  (define-public python-whisper
 (define-public python-carbon
   (package
     (name "python-carbon")
-    (version "1.1.8")
+    (version "1.1.10")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "carbon" version))
        (sha256
         (base32
-         "1wb91fipk1niciffq5xwqbh8g7rl7ghdam4m97cjbig12i5qr4cm"))))
-    (build-system python-build-system)
+         "0p6yjxif5ly5wkllnaw41w2zy9y0nffgfk91v861fn6c26lmnfy1"))))
+    (build-system pyproject-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          ;; Don't install to /opt
          (add-after 'unpack 'do-not-install-to-/opt
            (lambda _ (setenv "GRAPHITE_NO_PREFIX" "1") #t)))))
+    (native-inputs (list python-setuptools python-wheel))
     (propagated-inputs
-     (list python-cachetools python-txamqp python-urllib3 python-whisper))
+     (list python-cachetools python-twisted python-txamqp python-urllib3))
     (home-page "https://graphiteapp.org/")
     (synopsis "Backend data caching and persistence daemon for Graphite")
     (description "Carbon is a backend data caching and persistence daemon for