[bug#76835,v3,29/40] gnu: Add python-snakemake-interface-executor-plugins.

Message ID 20250310021652.17530-29-ngraves@ngraves.fr
State New
Headers
Series [bug#76835,v3,01/40] gnu: gunicorn: Migrate 'check phase to pyproject-build-system. |

Commit Message

Nicolas Graves March 10, 2025, 2:16 a.m. UTC
  * gnu/packages/python-science.scm
(python-snakemake-interface-executor-plugins): New variable.
---
 gnu/packages/python-science.scm | 34 +++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
  

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index d0a354a8c6..54b04abf71 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -962,6 +962,40 @@  (define-public python-snakemake-interface-common
 for Snakemake and its plugins.")
     (license license:expat)))
 
+(define-public python-snakemake-interface-executor-plugins
+  (package
+    (name "python-snakemake-interface-executor-plugins")
+    (version "9.3.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "\
+https://github.com/snakemake/snakemake-interface-executor-plugins")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1kjjcgkk1rbavb687x5ayw35ayhsnhpg9262k317x911wqpsj2fm"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests?
+                     (invoke "python3" "tests/tests.py")))))))
+    (propagated-inputs (list python-argparse-dataclass
+                             python-snakemake-interface-common
+                             python-throttler))
+    (native-inputs (list python-poetry-core python-pytest))
+    (home-page "\
+https://github.com/snakemake/python-snakemake-interface-executor-plugins")
+    (synopsis "Interface for Snakemake executor plugins")
+    (description
+     "This package provides a stable interface for interactions between Snakemake and
+its executor plugins.")
+    (license license:expat)))
+
 (define-public python-tdda
   (package
     (name "python-tdda")