[bug#76835,v3,26/40] gnu: python-yte: Update to 1.7.0.
Commit Message
* gnu/packages/python-xyz.scm (python-yte): Update to 1.7.0.
---
gnu/packages/python-xyz.scm | 26 ++++++++++++++++----------
1 file changed, 16 insertions(+), 10 deletions(-)
@@ -15319,20 +15319,26 @@ (define-public python-plac
(define-public python-yte
(package
(name "python-yte")
- (version "1.2.0")
+ (version "1.7.0")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "yte" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/koesterlab/yte")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "07hm1warpqi4ifqgkaz5sg887x4a44yhxafmpf835ywnpchg4s03"))))
- (build-system python-build-system)
+ (base32 "01hxl47bfb0jp2rh6qb6wrm6m8p5rfk21gksqb8qxxv9a037dnsv"))))
+ (build-system pyproject-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'set-HOME
- (lambda _ (setenv "HOME" "/tmp"))))))
- (propagated-inputs (list python-plac python-pyyaml))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "tests.py")))))))
+ (native-inputs (list python-numpy python-poetry-core python-pytest))
+ (propagated-inputs (list python-dpath python-plac python-pyyaml))
(home-page "https://github.com/koesterlab/yte")
(synopsis "YAML template engine with Python expressions")
(description