[bug#76835,v3,25/40] gnu: python-dpath: Update to 2.2.0.

Message ID 20250310021652.17530-25-ngraves@ngraves.fr
State New
Headers
Series [bug#76835,v3,01/40] gnu: gunicorn: Migrate 'check phase to pyproject-build-system. |

Commit Message

Nicolas Graves March 10, 2025, 2:16 a.m. UTC
  * gnu/packages/python-xyz.scm (python-dpath): Update to 2.2.0.
[source]: Switch to git-fetch.
[build-system]: Switch from python-build-system to
pyproject-build-system.
[native-inputs]: Remove python-mock. Replace python-nose by
python-nose2. Add python-setuptools and python-wheel.
---
 gnu/packages/python-xyz.scm | 27 ++++++++++++---------------
 1 file changed, 12 insertions(+), 15 deletions(-)
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ace13dd419..58b2436f7a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -34488,25 +34488,22 @@  (define-public python-dparse
 (define-public python-dpath
   (package
     (name "python-dpath")
-    (version "2.0.1")
+    (version "2.2.0")
     (source
      (origin
-       (method url-fetch)
-       (uri (pypi-uri "dpath" version))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/akesterson/dpath-python")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "1ymi9ssk7i0mx3mviplf4csfvzibdd6wyj4qzj6s487n9xgnp85y"))))
-    (build-system python-build-system)
+        (base32 "1rxgkn2dzakwdw5idkx0092yrmf46zcqx3xp87xksvxpzbsvz4nf"))))
+    (build-system pyproject-build-system)
     (native-inputs
-     (list python-hypothesis python-mock python-nose))
-    (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (add-installed-pythonpath inputs outputs)
-             ;; This invocation is taken from tox.ini.
-             (invoke "nosetests" "-d" "-v" "tests/"))))))
+     (list python-hypothesis
+           python-nose2
+           python-setuptools
+           python-wheel))
     (home-page "https://github.com/akesterson/dpath-python")
     (synopsis "File-system-like pathing and searching for dictionaries")
     (description