[bug#76835,v3,02/40] gnu: python-unyt: Avoid deprecation failure in tests.

Message ID 20250310021652.17530-2-ngraves@ngraves.fr
State New
Headers
Series [bug#76835,v3,01/40] gnu: gunicorn: Migrate 'check phase to pyproject-build-system. |

Commit Message

Nicolas Graves March 10, 2025, 2:16 a.m. UTC
  * gnu/packages/python-science.scm (python-unyt)[arguments]
{test-flags}: Ignore failing test.
---
 gnu/packages/python-science.scm | 3 +++
 1 file changed, 3 insertions(+)
  

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 2fa57f0ab5..ca259356cf 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -2526,6 +2526,9 @@  (define-public python-unyt
        (sha256
         (base32 "0jrq2vhan2h280h6cw1sm5hys2nzmf19w4py64k3nrkc320z9mni"))))
     (build-system pyproject-build-system)
+    (arguments
+     ;; This is a Numpy DeprecationWarning, remove it on next update.
+     (list #:test-flags ''("-k" "not test_h5_io")))
     ;; Pint is optional, but we do not propagate it due to its size.
     (native-inputs
      (list python-pint