[bug#76835,v3,01/40] gnu: gunicorn: Migrate 'check phase to pyproject-build-system.
Commit Message
* gnu/packages/python-web.scm (gunicorn)[arguments]
{phases}: Remove 'check phase and migrate its flags to...
{test-flags}: ...here.
---
gnu/packages/python-web.scm | 16 +++++-----------
1 file changed, 5 insertions(+), 11 deletions(-)
@@ -7304,23 +7304,17 @@ (define-public gunicorn
(outputs '("out" "doc"))
(build-system pyproject-build-system)
(arguments
- `(#:phases
+ `(#:test-flags
+ ;; Disable the geventlet tests because eventlet uses dnspython, which
+ ;; does not work in the build container due to lack of /etc/resolv.conf
+ '("--ignore=tests/workers/test_geventlet.py")
+ #:phases
(modify-phases %standard-phases
(add-after 'build 'build-doc
(lambda _
(invoke "make" "-C" "docs" "PAPER=a4" "html" "info")
(delete-file "docs/build/texinfo/Makefile")
(delete-file "docs/build/texinfo/Gunicorn.texi")))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (if tests?
- (begin
- (invoke "pytest" "-vv"
- ;; Disable the geventlet tests because eventlet uses
- ;; dnspython, which does not work in the build
- ;; container due to lack of /etc/resolv.conf, etc.
- "--ignore=tests/workers/test_geventlet.py"))
- (format #t "test suite not run~%"))))
(add-after 'install 'install-doc
(lambda* (#:key outputs #:allow-other-keys)
(let* ((doc (string-append (assoc-ref outputs "doc")