[bug#76835,v2,21/24] gnu: sphinx-5: Ignore failing test.

Message ID 20250309221153.334-21-ngraves@ngraves.fr
State New
Headers
Series [bug#76835,v2,01/24] gnu: gunicorn: Migrate 'check phase to pyproject-build-system. |

Commit Message

Nicolas Graves March 9, 2025, 10:11 p.m. UTC
  * gnu/packages/sphinx.scm (sphinx-5)[arguments]{test-flags}: Ignore
test test_autodoc_default_options (also ignored in sphinx@6).
---
 gnu/packages/sphinx.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
  

Patch

diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 239a2cc780..4b3e598e38 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -197,7 +197,10 @@  (define-public python-sphinx-5
               " and not test_viewcode"
               ;; These fail with pygments 2.10+.  They are harmless.
               " and not test_additional_targets_should_not_be_translated"
-              " and not test_additional_targets_should_be_translated"))
+              " and not test_additional_targets_should_be_translated"
+              ;; As in Sphinx@6:
+              ;; AssertionError: assert...list of weak references to the object...
+              " and not test_autodoc_default_options"))
       #:phases
       '(modify-phases %standard-phases
          (add-before 'check 'pre-check