[bug#76835,v2,11/24] gnu: python-uqbar: Update to 7.0.0.
Commit Message
* gnu/packages/graphviz.scm (python-uqbar): Update to 7.0.0.
[propagated-inputs]: Replace python-sphinx-5 by python-sphinx,
recursively.
---
gnu/packages/graphviz.scm | 11 +++--------
1 file changed, 3 insertions(+), 8 deletions(-)
@@ -208,7 +208,7 @@ (define-public python-pygraphviz
(define-public python-uqbar
(package
(name "python-uqbar")
- (version "0.6.9")
+ (version "7.0.0")
(source
(origin
(method git-fetch)
@@ -217,7 +217,7 @@ (define-public python-uqbar
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "037qj3rymm6xzdpklddfhmfp2p1bq9fi3jrvxj6gmharphd5z869"))))
+ (base32 "0qa32d2z7bg3h26r18dv55g9lghw59wln7rkcciavyyjh553q430"))))
(build-system pyproject-build-system)
(arguments ; XXX: Disable failing tests.
(list #:test-flags '(list "tests" "-k" "not test_find_executable \
@@ -232,12 +232,7 @@ (define-public python-uqbar
python-setuptools
python-wheel))
(propagated-inputs
- (list python-black python-sphinx-5 python-unidecode
- (package/inherit python-sphinx-rtd-theme
- (propagated-inputs
- (modify-inputs
- (package-propagated-inputs python-sphinx-rtd-theme)
- (replace "python-sphinx" python-sphinx-5))))))
+ (list python-black python-sphinx python-unidecode python-sphinx-rtd-theme))
(home-page "https://github.com/josiah-wolf-oberholtzer/uqbar")
(synopsis "Tools for building documentation with Sphinx, Graphviz and LaTeX")
(description