[bug#76422,v3] gnu: mozjs: Remove version 91.
Commit Message
No packages depend on this version anymore.
* gnu/packages/gnuzilla.scm (mozjs-91): Delete variable.
Change-Id: Icc4efd0fc8b3728e4e6c6953fe3266262358d193
---
gnu/packages/gnuzilla.scm | 31 -------------------------------
1 file changed, 31 deletions(-)
base-commit: 535efb3c9add7e32530aa0dced40b18b12b8ed95
Comments
André Batista <nandre@riseup.net> skribis:
> No packages depend on this version anymore.
>
> * gnu/packages/gnuzilla.scm (mozjs-91): Delete variable.
>
> Change-Id: Icc4efd0fc8b3728e4e6c6953fe3266262358d193
According to the deprecation policy¹, we can push this after March 19th
if nobody objects.
Thanks,
Ludo’.
¹ https://guix.gnu.org/manual/devel/en/html_node/Deprecation-Policy.html
Am Sat, Mar 08, 2025 at 10:09:50AM -0300 schrieb André Batista:
> No packages depend on this version anymore.
> * gnu/packages/gnuzilla.scm (mozjs-91): Delete variable.
Pushed, thanks!
Andreas
@@ -272,37 +272,6 @@ (define-public mozjs-102
(inputs (modify-inputs (package-inputs mozjs)
(replace "icu4c" icu4c-71)))))
-(define-public mozjs-91
- (package
- (inherit mozjs)
- (version "91.13.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://ftp.mozilla.org/pub/firefox"
- "/releases/" version "esr/source/firefox-"
- version "esr.source.tar.xz"))
- (sha256
- (base32
- "0qh7j960wdp5zcfqhkj8ki47spp9i9ms12xx0v0kxvmmw36jpgjk"))))
- (arguments
- (substitute-keyword-arguments (package-arguments mozjs)
- ((#:phases phases)
- #~(modify-phases #$phases
- (add-before 'check 'disable-timezone-tests
- (lambda _
- (with-directory-excursion "../js/src/tests"
- ;; FIXME: Assertion failed: got "2021a", expected "2021a3"?
- (delete-file "non262/Intl/DateTimeFormat/timeZone_version.js")
- ;; XXX: Delete all tests that test time zone functionality,
- ;; because the test suite uses /etc/localtime to figure out
- ;; the offset from the hardware clock, which does not work
- ;; in the build container. See <tests/non262/Date/shell.js>.
- (delete-file-recursively "non262/Date")
- (delete-file
- "non262/Intl/DateTimeFormat/tz-environment-variable.js"))))))))
- (inputs (modify-inputs (package-inputs mozjs)
- (replace "icu4c" icu4c-69)))))
-
(define-public mozjs-78
(package
(inherit mozjs)