[bug#75677,rust-team,v2,79/81] gnu: rust-newline-converter-0.3: New variable.

Message ID 20250308033446.2101481-80-aaron.covrig.us@ieee.org
State New
Headers
Series Assorted package updates for rust-team |

Commit Message

Aaron Covrig March 8, 2025, 3:34 a.m. UTC
  * gnu/packages/crates-io.scm (rust-newline-converter-0.3): New variable.
---
 gnu/packages/crates-io.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
  

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ae338de7a6..2c99d0970b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -47179,6 +47179,33 @@  (define-public rust-new-string-template-1
      "This package provides a customizable string-templating library for Rust.")
     (license license:expat)))
 
+(define-public rust-newline-converter-0.3
+  (package
+    (name "rust-newline-converter")
+    (version "0.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "newline-converter" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0zyw2hyjl89rj1zmp9n8fq69pbfp9zl1cbal73agxjxixjbv1dj7"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-unicode-segmentation" ,rust-unicode-segmentation-1))
+       #:cargo-development-inputs (("rust-criterion" ,rust-criterion-0.4)
+                                   ("rust-fancy-regex" ,rust-fancy-regex-0.10)
+                                   ("rust-lazy-regex" ,rust-lazy-regex-2)
+                                   ("rust-once-cell" ,rust-once-cell-1)
+                                   ("rust-quickcheck" ,rust-quickcheck-1))))
+    (home-page "https://github.com/spitfire05/rnc/tree/master/crates/newline-converter")
+    (synopsis "Newline byte converter library")
+    (description
+     "newline-converter is a simple library used for converting the newline
+characters in strings between Windows \r\n and Unix \n style.  It mainly serves
+as a backend for Rust Newline converter CLI tool.")
+    (license license:expat)))
+
 ;; Keep this package for future packaging of NewsFlash.
 (define-public rust-news-flash-1
   (package