[bug#75677,rust-team,v2,61/81] gnu: rust-utoipa-4: New variable.

Message ID 20250308033446.2101481-62-aaron.covrig.us@ieee.org
State New
Headers
Series Assorted package updates for rust-team |

Commit Message

Aaron Covrig March 8, 2025, 3:34 a.m. UTC
  * gnu/packages/crates-io.scm (rust-utoipa-4): New variable.
---
 gnu/packages/crates-io.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
  

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index dc440776ad..8e41232e18 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -91489,6 +91489,40 @@  (define-public rust-utf8parse-0.1
         (base32
          "0zamsj2986shm4x9zncjf2m5qy9scaw7qnxw4f89b2afpg6a8wl7"))))))
 
+(define-public rust-utoipa-4
+  (package
+    (name "rust-utoipa")
+    (version "4.2.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "utoipa" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "08xbxz3an28g0rv9agmqs1qix4nrrzppylw24r8clz901skb3by5"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-test-flags '("--features" "debug")
+       #:cargo-inputs (("rust-indexmap" ,rust-indexmap-2)
+                       ("rust-serde" ,rust-serde-1)
+                       ("rust-serde-json" ,rust-serde-json-1)
+                       ("rust-utoipia-gen" ,rust-utoipa-gen-4)
+                       ("rust-url" ,rust-url-2)
+                       ("rust-serde-yaml" ,rust-serde-yaml-0.9))
+       #:cargo-development-inputs (("rust-assert-json-diff" ,rust-assert-json-diff-2))))
+    (home-page "https://github.com/juhaku/utoipa")
+    (synopsis "Compile time generated OpenAPI documentation for Rust")
+    (description
+     "The utoipa crate provides auto-generated OpenAPI documentation for Rust
+REST APIs.  It treats code-first approach as a first class citizen and
+simplifies API documentation by providing simple macros for generating the
+documentation from your code.
+
+It also contains Rust types of the OpenAPI spec, allowing you to write the
+OpenAPI spec only using Rust if auto generation is not your flavor or does not
+fit your purpose.")
+    (license (list license:asl2.0 license:expat))))
+
 (define-public rust-utoipa-gen-4
   (package
     (name "rust-utoipa-gen")