[bug#75677,rust-team,v2,60/81] gnu: rust-utoipa-gen-4: New variable.

Message ID 20250308033446.2101481-61-aaron.covrig.us@ieee.org
State New
Headers
Series Assorted package updates for rust-team |

Commit Message

Aaron Covrig March 8, 2025, 3:34 a.m. UTC
  * gnu/packages/crates-io.scm (rust-utoipa-gen-4): New variable.
---
 gnu/packages/crates-io.scm | 46 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)
  

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 685d83e54e..dc440776ad 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -91489,6 +91489,52 @@  (define-public rust-utf8parse-0.1
         (base32
          "0zamsj2986shm4x9zncjf2m5qy9scaw7qnxw4f89b2afpg6a8wl7"))))))
 
+(define-public rust-utoipa-gen-4
+  (package
+    (name "rust-utoipa-gen")
+    (version "4.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "utoipa-gen" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "14j3bim9igkqpzmgxc6i2rj1wq1mandx68mdd9sfxycgns54xhi0"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:tests? #f ;use of undeclared crate or module `utoipa`
+       #:cargo-inputs (("rust-proc-macro-error" ,rust-proc-macro-error-1)
+                       ("rust-proc-macro2" ,rust-proc-macro2-1)
+                       ("rust-quote" ,rust-quote-1)
+                       ("rust-syn" ,rust-syn-2)
+                       ("rust-regex" ,rust-regex-1)
+                       ("rust-ulid" ,rust-ulid-1)
+                       ("rust-url" ,rust-url-2)
+                       ("rust-uuid" ,rust-uuid-1))
+       #:cargo-development-inputs (("rust-actix-web" ,rust-actix-web-4)
+                                   ("rust-assert-json-diff" ,rust-assert-json-diff-2)
+                                   ("rust-axum" ,rust-axum-0.7)
+                                   ("rust-chrono" ,rust-chrono-0.4)
+                                   ("rust-paste" ,rust-paste-1)
+                                   ("rust-rocket" ,rust-rocket-0.5)
+                                   ("rust-serde" ,rust-serde-1)
+                                   ("rust-serde-json" ,rust-serde-json-1)
+                                   ("rust-serde-with" ,rust-serde-with-3)
+                                   ("rust-smallvec" ,rust-smallvec-1)
+                                   ("rust-time" ,rust-time-0.3))))
+    (home-page "https://github.com/juhaku/utoipa")
+    (synopsis "Code generation implementation for utoipa")
+    (description
+     "The utoipa crate provides auto-generated OpenAPI documentation for Rust
+REST APIs.  It treats code-first approach as a first class citizen and
+simplifies API documentation by providing simple macros for generating the
+documentation from your code.
+
+It also contains Rust types of the OpenAPI spec, allowing you to write the
+OpenAPI spec only using Rust if auto generation is not your flavor or does not
+fit your purpose.")
+    (license (list license:asl2.0 license:expat))))
+
 (define-public rust-uu-cp-0.0.28
   (package
     (name "rust-uu-cp")