[bug#75677,rust-team,v2,47/81] gnu: rust-postgres-protocol-0.6: Upgrade to v0.6.7

Message ID 20250308033446.2101481-48-aaron.covrig.us@ieee.org
State New
Headers
Series Assorted package updates for rust-team |

Commit Message

Aaron Covrig March 8, 2025, 3:33 a.m. UTC
  * gnu/packages/crates-database.scm (rust-postgres-protocol-0.6): Upgrade
  to v0.6.7
---
 gnu/packages/crates-database.scm | 14 ++++++++------
 1 file changed, 8 insertions(+), 6 deletions(-)
  

Patch

diff --git a/gnu/packages/crates-database.scm b/gnu/packages/crates-database.scm
index da032a47f4..61c07f55fd 100644
--- a/gnu/packages/crates-database.scm
+++ b/gnu/packages/crates-database.scm
@@ -9,6 +9,7 @@ 
 ;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
 ;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
 ;;; Copyright © 2024 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2025 Aaron Covrig <aaron.covrig.us@ieee.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -572,7 +573,7 @@  (define-public rust-postgres-derive-0.4
 (define-public rust-postgres-protocol-0.6
   (package
     (name "rust-postgres-protocol")
-    (version "0.6.1")
+    (version "0.6.7")
     (source
       (origin
         (method url-fetch)
@@ -581,19 +582,20 @@  (define-public rust-postgres-protocol-0.6
          (string-append name "-" version ".tar.gz"))
         (sha256
          (base32
-          "1wxzs78zvz00bh3bhbbp9hnq9hg77f8h5pzjmcy9481fsdq0ygpz"))))
+          "08sbm36w68vyrzaaxiv8srrr1w65wi8ycdgf9flfz2y2xfyhxnmc"))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
-       (("rust-base64" ,rust-base64-0.13)
+       (("rust-base64" ,rust-base64-0.22)
         ("rust-byteorder" ,rust-byteorder-1)
         ("rust-bytes" ,rust-bytes-1)
         ("rust-fallible-iterator" ,rust-fallible-iterator-0.2)
-        ("rust-hmac" ,rust-hmac-0.10)
-        ("rust-md-5" ,rust-md-5-0.9)
+        ("rust-getrandom" ,rust-getrandom-0.2)
+        ("rust-hmac" ,rust-hmac-0.12)
+        ("rust-md-5" ,rust-md-5-0.10)
         ("rust-memchr" ,rust-memchr-2)
         ("rust-rand" ,rust-rand-0.8)
-        ("rust-sha2" ,rust-sha2-0.9)
+        ("rust-sha2" ,rust-sha2-0.10)
         ("rust-stringprep" ,rust-stringprep-0.1))))
     (home-page "https://github.com/sfackler/rust-postgres")
     (synopsis "Low level Postgres protocol APIs")