[bug#76846] gnu: Add lxqt-wallet
Commit Message
* gnu/packages/lxqt.scm (lxqt-wallet): New variable.
* gnu/packages/lxqt.scm (lxqt-wallet-3): New variable.
* gnu/packages/lxqt.scm (lxqt-wallet-2): New variable.
---
gnu/packages/lxqt.scm | 61 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 61 insertions(+)
base-commit: c8bde3c6725be4eb0743a153a3cf8de453d9e448
Comments
Hi Aaron,
Aaron Covrig via Guix-patches via <guix-patches@gnu.org> writes:
> * gnu/packages/lxqt.scm (lxqt-wallet): New variable.
> * gnu/packages/lxqt.scm (lxqt-wallet-3): New variable.
> * gnu/packages/lxqt.scm (lxqt-wallet-2): New variable.
> ---
> gnu/packages/lxqt.scm | 61 +++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 61 insertions(+)
>
> diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
> index 45db8bdc6e..748170d23c 100644
> --- a/gnu/packages/lxqt.scm
> +++ b/gnu/packages/lxqt.scm
> @@ -12,6 +12,7 @@
> ;;; Copyright © 2020 André Batista <nandre@riseup.net>
> ;;; Copyright © 2021, 2022 Brendan Tildesley <mail@brendan.scot>
> ;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
> +;;; Copyright © 2024 Aaron Covrig <aaron.covrig.us@ieee.org>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -866,6 +867,66 @@ (define-public lximage-qt
> image viewer.")
> (license license:gpl2+)))
>
> +(define-public lxqt-wallet
> + (package
> + (name "lxqt-wallet")
> + (version "4.0.2")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/lxqt/lxqt_wallet")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "0krs2x4ivx9n3q98v0q91f53q19rji3qhv5rl9xbhgylxralr135"))))
> + (build-system cmake-build-system)
> + (arguments '(#:tests? #f)) ;No tests
> + (inputs (list libsecret qtbase qttools kwallet))
> + (home-page "https://github.com/lxqt/lxqt_wallet")
> + (synopsis "Create KWallet like functionality for LXQT")
> + (description
> + "This project seeks to give a functionality for secure storage
> +of information that can be presented in key-values pair like user
> +names-passwords pairs.")
> + (license license:expat)))
> +
> +(define-public lxqt-wallet-3
> + (package
> + (inherit lxqt-wallet)
> + (name "lxqt-wallet")
> + (version "3.2.2")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/lxqt/lxqt_wallet")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "0s1q4bjgla4bpnh2zbpian7wfrq53wyp8gl7hqazfgnh5vrhdhml"))))
> + (arguments '(#:tests? #f)) ;No tests
> + (inputs (list libsecret qtbase-5 qttools-5 kwallet-5))))
> +
> +(define-public lxqt-wallet-2
> + (package
> + (inherit lxqt-wallet-3)
> + (name "lxqt-wallet")
> + (version "2.2.1")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/lxqt/lxqt_wallet")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "1syidgsvn4355z2qdpr5cjwlwmik1h83z5k60fgyni0hli86w1v7"))))
> + (arguments
> + '(#:tests? #f ;No tests
> + #:configure-flags '( "-DQT5=true")))
> + (inputs (list libsecret qtbase-5))))
> +
> (define-public obconf-qt
> (package
> (name "obconf-qt")
>
> base-commit: c8bde3c6725be4eb0743a153a3cf8de453d9e448
Just out of curiousity, any reason to provide lxqt-wallet-3 (released
2021) and lxqt-wallet-2 (released 2016)? If they're not needed for
anything, they can be skipped.
They should be fine to be dropped, the main reason for including them was
to potentially support older versions of QT if desired (lxqt-wallet-4 is
QT6 only).
v/r,
Aaron
On Fri, Mar 7, 2025, 21:21 James Smith <jsubuntuxp@disroot.org> wrote:
> Hi Aaron,
>
> Aaron Covrig via Guix-patches via <guix-patches@gnu.org> writes:
>
> > * gnu/packages/lxqt.scm (lxqt-wallet): New variable.
> > * gnu/packages/lxqt.scm (lxqt-wallet-3): New variable.
> > * gnu/packages/lxqt.scm (lxqt-wallet-2): New variable.
> > ---
> > gnu/packages/lxqt.scm | 61 +++++++++++++++++++++++++++++++++++++++++++
> > 1 file changed, 61 insertions(+)
> >
> > diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
> > index 45db8bdc6e..748170d23c 100644
> > --- a/gnu/packages/lxqt.scm
> > +++ b/gnu/packages/lxqt.scm
> > @@ -12,6 +12,7 @@
> > ;;; Copyright © 2020 André Batista <nandre@riseup.net>
> > ;;; Copyright © 2021, 2022 Brendan Tildesley <mail@brendan.scot>
> > ;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
> > +;;; Copyright © 2024 Aaron Covrig <aaron.covrig.us@ieee.org>
> > ;;;
> > ;;; This file is part of GNU Guix.
> > ;;;
> > @@ -866,6 +867,66 @@ (define-public lximage-qt
> > image viewer.")
> > (license license:gpl2+)))
> >
> > +(define-public lxqt-wallet
> > + (package
> > + (name "lxqt-wallet")
> > + (version "4.0.2")
> > + (source
> > + (origin
> > + (method git-fetch)
> > + (uri (git-reference
> > + (url "https://github.com/lxqt/lxqt_wallet")
> > + (commit version)))
> > + (file-name (git-file-name name version))
> > + (sha256
> > + (base32
> "0krs2x4ivx9n3q98v0q91f53q19rji3qhv5rl9xbhgylxralr135"))))
> > + (build-system cmake-build-system)
> > + (arguments '(#:tests? #f)) ;No tests
> > + (inputs (list libsecret qtbase qttools kwallet))
> > + (home-page "https://github.com/lxqt/lxqt_wallet")
> > + (synopsis "Create KWallet like functionality for LXQT")
> > + (description
> > + "This project seeks to give a functionality for secure storage
> > +of information that can be presented in key-values pair like user
> > +names-passwords pairs.")
> > + (license license:expat)))
> > +
> > +(define-public lxqt-wallet-3
> > + (package
> > + (inherit lxqt-wallet)
> > + (name "lxqt-wallet")
> > + (version "3.2.2")
> > + (source
> > + (origin
> > + (method git-fetch)
> > + (uri (git-reference
> > + (url "https://github.com/lxqt/lxqt_wallet")
> > + (commit version)))
> > + (file-name (git-file-name name version))
> > + (sha256
> > + (base32
> "0s1q4bjgla4bpnh2zbpian7wfrq53wyp8gl7hqazfgnh5vrhdhml"))))
> > + (arguments '(#:tests? #f)) ;No tests
> > + (inputs (list libsecret qtbase-5 qttools-5 kwallet-5))))
> > +
> > +(define-public lxqt-wallet-2
> > + (package
> > + (inherit lxqt-wallet-3)
> > + (name "lxqt-wallet")
> > + (version "2.2.1")
> > + (source
> > + (origin
> > + (method git-fetch)
> > + (uri (git-reference
> > + (url "https://github.com/lxqt/lxqt_wallet")
> > + (commit version)))
> > + (file-name (git-file-name name version))
> > + (sha256
> > + (base32
> "1syidgsvn4355z2qdpr5cjwlwmik1h83z5k60fgyni0hli86w1v7"))))
> > + (arguments
> > + '(#:tests? #f ;No tests
> > + #:configure-flags '( "-DQT5=true")))
> > + (inputs (list libsecret qtbase-5))))
> > +
> > (define-public obconf-qt
> > (package
> > (name "obconf-qt")
> >
> > base-commit: c8bde3c6725be4eb0743a153a3cf8de453d9e448
>
> Just out of curiousity, any reason to provide lxqt-wallet-3 (released
> 2021) and lxqt-wallet-2 (released 2016)? If they're not needed for
> anything, they can be skipped.
>
Hello,
thanks for the patch, and thanks for the enquiry about the three
versions! Indeed unless there is a particular reason, we only keep the
latest version of each software project in Guix.
The license was not correct (it is bsd-2, see the file guix/licenses.scm).
I will push the commit with these few changes, and am closing this
issue.
Thanks again,
Andreas
@@ -12,6 +12,7 @@
;;; Copyright © 2020 André Batista <nandre@riseup.net>
;;; Copyright © 2021, 2022 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2024 Aaron Covrig <aaron.covrig.us@ieee.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -866,6 +867,66 @@ (define-public lximage-qt
image viewer.")
(license license:gpl2+)))
+(define-public lxqt-wallet
+ (package
+ (name "lxqt-wallet")
+ (version "4.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lxqt/lxqt_wallet")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0krs2x4ivx9n3q98v0q91f53q19rji3qhv5rl9xbhgylxralr135"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f)) ;No tests
+ (inputs (list libsecret qtbase qttools kwallet))
+ (home-page "https://github.com/lxqt/lxqt_wallet")
+ (synopsis "Create KWallet like functionality for LXQT")
+ (description
+ "This project seeks to give a functionality for secure storage
+of information that can be presented in key-values pair like user
+names-passwords pairs.")
+ (license license:expat)))
+
+(define-public lxqt-wallet-3
+ (package
+ (inherit lxqt-wallet)
+ (name "lxqt-wallet")
+ (version "3.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lxqt/lxqt_wallet")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0s1q4bjgla4bpnh2zbpian7wfrq53wyp8gl7hqazfgnh5vrhdhml"))))
+ (arguments '(#:tests? #f)) ;No tests
+ (inputs (list libsecret qtbase-5 qttools-5 kwallet-5))))
+
+(define-public lxqt-wallet-2
+ (package
+ (inherit lxqt-wallet-3)
+ (name "lxqt-wallet")
+ (version "2.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lxqt/lxqt_wallet")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1syidgsvn4355z2qdpr5cjwlwmik1h83z5k60fgyni0hli86w1v7"))))
+ (arguments
+ '(#:tests? #f ;No tests
+ #:configure-flags '( "-DQT5=true")))
+ (inputs (list libsecret qtbase-5))))
+
(define-public obconf-qt
(package
(name "obconf-qt")