[bug#76819,v7,29/35] gnu: git: Use lint-hidden-cpe-vendors.

Message ID 20250307183914.8825-29-ngraves@ngraves.fr
State New
Headers
Series Add lint-hidden-cpe-vendors property |

Commit Message

Nicolas Graves March 7, 2025, 6:38 p.m. UTC
  * gnu/packages/version-control.scm (git-minimal, git)[properties]: Use
lint-hidden-cpe-vendors in place of lint-hidden-cve.
---
 gnu/packages/version-control.scm | 15 +--------------
 1 file changed, 1 insertion(+), 14 deletions(-)
  

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 4b66fa02fb..d85bdbe9c4 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -589,20 +589,7 @@  (define PATH-variable-definition
     (description
      "Git is a free distributed version control system designed to handle
 everything from small to very large projects with speed and efficiency.")
-    ;; XXX: Ignore this CVE to work around a name clash with the unrelated
-    ;; "cpe:2.3:a:jenkins:git" package.  The proper fix is for (guix cve) to
-    ;; account for "vendor names".
-    (properties '((lint-hidden-cve . ("CVE-2018-1000182"
-                                      "CVE-2018-1000110"
-                                      "CVE-2019-1003010"
-                                      "CVE-2020-2136"
-                                      "CVE-2021-21684"
-                                      "CVE-2022-30947"
-                                      "CVE-2022-30948"
-                                      "CVE-2022-30949"
-                                      "CVE-2022-36882"
-                                      "CVE-2022-36883"
-                                      "CVE-2022-36884"))
+    (properties '((lint-hidden-cpe-vendors . ("jenkins"))
                   (upstream-name . "git")))
     (license license:gpl2)
     (home-page "https://git-scm.com/")))