[bug#76819,v7,20/35] gnu: opus: Add lint-hidden-cve property.

Message ID 20250307183914.8825-20-ngraves@ngraves.fr
State New
Headers
Series Add lint-hidden-cpe-vendors property |

Commit Message

Nicolas Graves March 7, 2025, 6:38 p.m. UTC
  * gnu/packages/xiph.scm (opus)[properties]: Add release-monitoring-url
and lint-hidden-cpe-vendors.
---
 gnu/packages/xiph.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
  

Patch

diff --git a/gnu/packages/xiph.scm b/gnu/packages/xiph.scm
index 7ca336b14a..7436cd1bd0 100644
--- a/gnu/packages/xiph.scm
+++ b/gnu/packages/xiph.scm
@@ -380,7 +380,10 @@  (define-public opus
 standardized by the Internet Engineering Task Force (IETF) as RFC 6716 which
 incorporated technology from Skype's SILK codec and Xiph.Org's CELT codec.")
     ;; This package shows a sizable speed increase when tuned.
-    (properties `((tunable? . #t)))
+    (properties `((tunable? . #t)
+                  (lint-hidden-cpe-vendors . ("discordjs"))
+                  (release-monitoring-url
+                   . "https://archive.mozilla.org/pub/opus/")))
     (license license:bsd-3)
     (home-page "https://www.opus-codec.org")))