[bug#73019,v6,3/3] gnu: Add blackbox-terminal.

Message ID 20250304122157.10899-4-ashvithshetty0010@zohomail.in
State New
Headers
Series gnu: Add blackbox-terminal. |

Commit Message

Ashvith Shetty March 4, 2025, 12:21 p.m. UTC
  * gnu/packages/gnome-xyz.scm (blackbox-terminal): New variable.

Change-Id: I72d1f0b475fd5cdea7fb0087149ac9eba7a8850b
---
 gnu/packages/gnome-xyz.scm | 45 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)
  

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index f168b8c722..d72b861f30 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -65,6 +65,7 @@  (define-module (gnu packages gnome-xyz)
   #:use-module (gnu packages ibus)
   #:use-module (gnu packages inkscape)
   #:use-module (gnu packages image)
+  #:use-module (gnu packages pcre)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-science)
@@ -1792,3 +1793,47 @@  (define-public libpqmarble
     (synopsis "Utility library for GNOME apps")
     (description "@code{libpqmarble} is a utility library for GNOME apps.")
     (license license:gpl3+)))
+
+(define-public blackbox-terminal
+  (package
+    (name "blackbox-terminal")
+    (version "0.14.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.gnome.org/raggesilver/blackbox")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0g7n2z0m7jjbn93zvx3ix7ph4mpncwq80cjjc2prp878cksj3g3r"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:glib-or-gtk? #t
+       #:configure-flags `("-Dblackbox_is_flatpak=false")
+       #:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'fix-gtk4-update-icon-cache
+                    (lambda _
+                      (substitute* "build-aux/meson/postinstall.py"
+                        (("gtk-update-icon-cache")
+                         "true")))))))
+    (native-inputs (list pkg-config
+                         vala
+                         python-3.10
+                         desktop-file-utils ;for update-desktop-database
+                         (list glib "bin") ;for glib-compile-schemas, etc.
+                         gettext-minimal))
+    (inputs (list gtk
+                  vte-0.73.92
+                  json-glib
+                  libpqmarble
+                  libadwaita
+                  pcre2
+                  libxml2
+                  libgee
+                  librsvg))
+    (home-page "https://gitlab.gnome.org/raggesilver/blackbox/")
+    (synopsis "Beautiful GTK 4 terminal")
+    (description
+     "@code{blackbox-terminal} is an elegant and customizable terminal for GNOME.")
+    (license license:gpl3+)))