[bug#73019,v6,2/3] gnu: Add vte-0.73.92.

Message ID 20250304122157.10899-3-ashvithshetty0010@zohomail.in
State New
Headers
Series gnu: Add blackbox-terminal. |

Commit Message

Ashvith Shetty March 4, 2025, 12:21 p.m. UTC
  * gnu/packages/gnome.scm (vte-0.73.92): New variable.

Change-Id: Ide1f88fc454155fa940ae2a63b6ed33e38f379f5
---
 gnu/packages/gnome.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
  

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6413deb18b..13963c29cc 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -79,6 +79,7 @@ 
 ;;; Copyright © 2023 Zhu Zihao <all_but_last@163.com>
 ;;; Copyright © 2024 Dariqq <dariqq@posteo.net>
 ;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
+;;; Copyright © 2025 Ashvith Shetty <ashvithshetty0010@zohomail.in>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -4722,6 +4723,26 @@  (define-public vte/gtk+-3
     (propagated-inputs (modify-inputs (package-propagated-inputs vte)
                          (replace "gtk" gtk+)))))
 
+(define-public vte-0.73.92
+  (package/inherit vte
+    (name "vte")
+    (version "0.73.92")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.gnome.org/GNOME/vte")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256 (base32
+                       "0fv6lx7kk1xrfsvc95jm23vxkmyfypriz4nvj0kjy4nshgccwlch"))))
+    (arguments (substitute-keyword-arguments (package-arguments vte)
+                 ((#:configure-flags flags)
+                  #~(append (list "-Dsixel=true")
+                            #$flags))))
+    (inputs (modify-inputs (package-inputs vte)
+              (append libsixel)
+              (append lz4)))))
+
 ;; Stable version for gtk2, required by gnurobots and lxterminal as of 2020-07.
 (define-public vte/gtk+-2
   (package (inherit vte)