[bug#73019,v6,1/3] gnu: Add libpqmarble.

Message ID 20250304122157.10899-2-ashvithshetty0010@zohomail.in
State New
Headers
Series gnu: Add blackbox-terminal. |

Commit Message

Ashvith Shetty March 4, 2025, 12:21 p.m. UTC
  * gnu/packages/gnome-xyz.scm (libpqmarble): New variable.

Change-Id: Ic7d6b6848656247cd43397e5c6b07261a08f6967
---
 gnu/packages/gnome-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
  

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 92d8b7cb03..f168b8c722 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -20,6 +20,7 @@ 
 ;;; Copyright © 2022 Sughosha <sughosha@proton.me>
 ;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
 ;;; Copyright © 2023 Eidvilas Markevičius <markeviciuseidvilas@gmail.com>
+;;; Copyright © 2025 Ashvith Shetty <ashvithshetty0010@zohomail.in>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1757,3 +1758,37 @@  (define-public tiramisu
 notifications to STDOUT in order to allow the user to process notifications any
 way they prefer.")
     (license license:expat)))
+
+(define-public libpqmarble
+  (package
+    (name "libpqmarble")
+    (version "2.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.gnome.org/raggesilver/marble")
+             ;; Tag for v2.0.0 is currently missing, so use commit instead
+             (commit "f240b2ec7d5cdacb8fdcc553703420dc5101ffdb")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0jx53yadqkcsfk9khkqmapznd8g9xg98wkgkigh964dj6gpp7fx1"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:glib-or-gtk? #t
+       #:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'fix-gtk4-update-icon-cache
+                    (lambda _
+                      (substitute* "build-aux/meson/postinstall.py"
+                        (("gtk-update-icon-cache")
+                         "true")))))))
+    (native-inputs (list pkg-config
+                         vala
+                         (list glib "bin") ;for glib-compile-schemas, etc.
+                         desktop-file-utils ;for update-desktop-database
+                         gobject-introspection))
+    (inputs (list gtk))
+    (home-page "https://gitlab.gnome.org/raggesilver/marble")
+    (synopsis "Utility library for GNOME apps")
+    (description "@code{libpqmarble} is a utility library for GNOME apps.")
+    (license license:gpl3+)))