[bug#76738,ruby-team,3/3] gnu: Remove python-sphinx-4.

Message ID 20250304115418.9768-3-ngraves@ngraves.fr
State New
Headers
Series [bug#76738,ruby-team,1/3] gnu: python-sphinx-panels: Update input to python-sphinx-5. |

Commit Message

Nicolas Graves March 4, 2025, 11:54 a.m. UTC
  * gnu/packages/sphinx.scm (python-sphinx-4): Delete variable.
---
 gnu/packages/sphinx.scm | 19 -------------------
 1 file changed, 19 deletions(-)
  

Patch

diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index aab665463f..73fc9e0ad5 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -262,25 +262,6 @@  (define-public python-sphinx-5
            (texlive-updmap.cfg
             (list texlive-cm-super texlive-tex-gyre))))))
 
-;; Some packages do not support Sphinx 5 yet.  Remove when unused.
-(define-public python-sphinx-4
-  (package
-    (inherit python-sphinx-5)
-    (version "4.5.0")
-    (source (origin
-              (method url-fetch)
-              (uri (pypi-uri "Sphinx" version))
-              (sha256
-               (base32
-                "1rp28jryxwy24y8vpacclqihbizyi6b1s6id86pibvm46ybcmy3v"))))
-    (propagated-inputs
-     (modify-inputs (package-propagated-inputs python-sphinx)
-       (replace "python-docutils" python-docutils-0.15)))
-    (native-inputs
-     (modify-inputs (package-native-inputs python-sphinx)
-       (delete python-flit-core)
-       (append python-setuptools python-wheel)))))
-
 (define-public python-sphinxcontrib-apidoc
   (package
     (name "python-sphinxcontrib-apidoc")