[bug#70858,v4,51/52] gnu: python-loguru: Remove python-pytest-mypy-plugins.

Message ID 20250226031112.15843-51-ngraves@ngraves.fr
State New
Headers
Series |

Commit Message

Nicolas Graves Feb. 26, 2025, 3:10 a.m. UTC
  * gnu/packages/python-xyz.scm (python-loguru)
[arguments]: Add in {test-flags} to skip the concerned test file.
[native-inputs]: Remove python-pytest-mypy-plugins.
---
 gnu/packages/python-xyz.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)
  

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c4c174bbbe..c8ccb422d2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -35035,11 +35035,12 @@  (define-public python-loguru
       #~(list"--numprocesses" (number->string (parallel-job-count))
              ;; All of these fail with: error: Cannot find implementation or
              ;; library stub for module named "loguru"
-             "--ignore=tests/typesafety/test_logger.yml")))
+             "--ignore=tests/typesafety/test_logger.yml"
+             ;; Removes mypy dependency
+             "--ignore=tests/test_type_hinting.py")))
     (native-inputs
      (list python-freezegun
            python-pytest
-           python-pytest-mypy-plugins
            python-pytest-xdist
            python-setuptools
            python-wheel))